PDA

View Full Version : Yum/dnf not starting, system-python error



zoeparman
3rd November 2017, 01:12 PM
For some reason, I can't start yum or dnf anymore. All I get is the following error:


/usr/libexec/system-python: symbol lookup error: /usr/libexec/system-python: undefined symbol: _Py_CoerceLegacyLocale

I really don't understand what I could have done that breaks this... Is it possible that conda and/or pip modules are conflicting? And if so, how can I detect this?

nobody
4th November 2017, 08:07 AM
Zoja,

You should check the following (from my Fedora 26 x86_64 VM over VMWare reader/WIN10 64):


[user@192 ~]$ rpm -qa | grep system-python
system-python-libs-3.6.2-8.fc26.x86_64
system-python-3.6.2-8.fc26.x86_64
[user@192 ~]$ rpm -qa | grep python
python-libxml2-2.9.4-2.fc26.x86_64
newt-python3-0.52.20-1.fc26.x86_64
python-ldap-2.4.25-3.fc26.x86_64
python2-hawkey-0.11.1-1.fc26.x86_64
python3-pillow-4.1.1-1.fc26.x86_64
audit-libs-python-2.8.1-1.fc26.x86_64
abrt-addon-python3-2.10.3-3.fc26.x86_64
python2-2.7.13-12.fc26.x86_64
python3-slip-dbus-0.6.4-6.fc26.noarch
python3-speechd-0.8.7-1.fc26.x86_64
python-xpyb-1.3.1-7.fc26.x86_64
setools-python-4.1.0-5.fc26.x86_64
python3-pyasn1-0.2.3-1.fc26.noarch
python3-libs-3.6.2-8.fc26.x86_64
python3-systemd-234-1.fc26.x86_64
policycoreutils-python3-2.6-6.fc26.x86_64
python3-configobj-5.0.6-8.fc26.noarch
python3-cryptography-2.0.2-1.fc26.x86_64
python-gobject-base-3.24.1-1.fc26.x86_64
python3-dmidecode-3.12.2-6.fc26.x86_64
python3-pyudev-0.21.0-3.fc26.noarch
python3-cffi-1.9.1-2.fc26.x86_64
python2-pyasn1-modules-0.2.3-1.fc26.noarch
python3-sssdconfig-1.15.3-5.fc26.noarch
python-keyczar-0.71c-8.fc26.noarch
abrt-python3-2.10.3-3.fc26.x86_64
python2-sphinxcontrib-websupport-1.0.1-1.fc26.noarch
python2-librepo-1.8.0-1.fc26.x86_64
python3-blockdev-2.12-1.fc26.x86_64
python2-pyparsing-2.1.10-3.fc26.noarch
python-enum34-1.1.6-1.fc26.noarch
python3-gpg-1.8.0-12.fc26.x86_64
python3-gobject-3.24.1-1.fc26.x86_64
python-srpm-macros-3-20.fc26.noarch
python2-setuptools-36.2.0-2.fc26.noarch
python3-enchant-1.6.10-1.fc26.noarch
python2-jmespath-0.9.0-7.fc26.noarch
python-backports-ssl_match_hostname-3.5.0.1-4.fc26.noarch
python-pwquality-1.3.0-8.fc26.x86_64
python2-paste-2.0.3-2.fc26.noarch
python3-pyxdg-0.25-12.fc26.noarch
python2-sqlalchemy-1.1.13-1.fc26.x86_64
python3-iniparse-0.4-24.fc26.noarch
python3-pyparted-3.10.7-6.fc26.x86_64
python3-async-timeout-1.2.0-1.fc26.noarch
python3-psutil-5.0.1-2.fc26.x86_64
python3-cssselect-0.9.2-4.fc26.noarch
python2-ply-3.9-3.fc26.noarch
python3-urllib3-1.20-1.fc26.noarch
python-ipaddr-2.1.10-6.fc26.noarch
python3-devel-3.6.2-8.fc26.x86_64
python3-pwquality-1.3.0-8.fc26.x86_64
langtable-python3-0.0.37-1.fc26.noarch
python-gobject-3.24.1-1.fc26.x86_64
python2-cryptography-2.0.2-1.fc26.x86_64
python-bugzilla-2.1.0-1.fc26.noarch
python3-six-1.10.0-9.fc26.noarch
python2-appdirs-1.4.3-1.fc26.noarch
libpeas-loader-python3-1.20.0-5.fc26.x86_64
python3-asn1crypto-0.23.0-1.fc26.noarch
system-python-libs-3.6.2-8.fc26.x86_64
python3-pycparser-2.14-10.fc26.noarch
python3-dbus-1.2.4-6.fc26.x86_64
python2-systemd-234-1.fc26.x86_64
python3-yarl-0.12.0-1.fc26.x86_64
python2-django-1.10.8-1.fc26.noarch
python-beaker-1.5.4-16.fc26.noarch
python3-caribou-0.4.21-3.fc26.noarch
python3-dnf-2.7.5-1.fc26.noarch
python2-blockdev-2.12-1.fc26.x86_64
python3-pyOpenSSL-16.2.0-6.fc26.noarch
python2-docutils-0.13.1-4.fc26.noarch
python2-pbr-1.10.0-4.fc26.noarch
python-backports-1.0-9.fc26.x86_64
python3-dnf-plugins-core-2.1.5-1.fc26.noarch
python2-funcsigs-1.0.2-5.fc26.noarch
python2-imagesize-0.7.1-5.fc26.noarch
python3-slip-0.6.4-6.fc26.noarch
python3-idna-2.5-1.fc26.noarch
libselinux-python3-2.6-7.fc26.x86_64
python-chardet-2.3.0-3.fc26.noarch
python3-meh-gui-0.44-4.fc26.noarch
python3-blivet-2.1.11-2.fc26.noarch
python2-kitchen-1.2.4-6.fc26.noarch
python-bugzilla-cli-2.1.0-1.fc26.noarch
python3-brlapi-0.6.6-5.fc26.x86_64
python-sphinx-locale-1.5.2-4.fc26.noarch
python2-snowballstemmer-1.2.1-3.fc26.noarch
libuser-python-0.62-6.fc26.x86_64
python3-librepo-1.8.0-1.fc26.x86_64
python2-pycparser-2.14-10.fc26.noarch
python3-3.6.2-8.fc26.x86_64
python2-mock-2.0.0-4.fc26.noarch
python3-wrapt-1.10.10-1.fc26.x86_64
python2-babel-2.3.4-5.fc26.noarch
python3-pyparsing-2.1.10-3.fc26.noarch
python2-pyasn1-0.2.3-1.fc26.noarch
python3-sip-4.19.1-1.fc26.x86_64
policycoreutils-python-2.6-6.fc26.x86_64
python2-jinja2-2.9.6-1.fc26.noarch
python2-pysocks-1.6.7-1.fc26.noarch
setools-python3-4.1.0-5.fc26.x86_64
python3-dnf-plugin-system-upgrade-2.0.3-1.fc26.noarch
python2-dnf-2.7.5-1.fc26.noarch
python-magic-5.30-11.fc26.noarch
python3-chardet-2.3.0-3.fc26.noarch
libsemanage-python-2.6-4.fc26.x86_64
python3-aiohttp-2.2.5-1.fc26.x86_64
libreport-python3-2.9.1-3.fc26.x86_64
python2-asn1crypto-0.23.0-1.fc26.noarch
python3-bugzilla-2.1.0-1.fc26.noarch
python3-jinja2-2.9.6-1.fc26.noarch
python3-dnf-plugins-extras-common-2.0.3-1.fc26.noarch
python3-distro-1.0.3-1.fc26.noarch
python2-iniparse-0.4-24.fc26.noarch
python2-dnf-plugin-system-upgrade-2.0.3-1.fc26.noarch
python-rpm-macros-3-20.fc26.noarch
python3-pygpgme-0.3-22.fc26.x86_64
python3-requests-file-1.4-6.fc26.noarch
python3-libxml2-2.9.4-2.fc26.x86_64
python-IPy-python3-0.81-18.fc26.noarch
python3-meh-0.44-4.fc26.noarch
python2-dnf-plugins-extras-common-2.0.3-1.fc26.noarch
python3-javapackages-4.7.0-17.fc26.noarch
python2-urllib3-1.20-1.fc26.noarch
python3-multidict-3.3.0-1.fc26.x86_64
python3-decorator-4.0.11-2.fc26.noarch
python3-augeas-0.5.0-8.fc26.noarch
python2-numpy-1.12.1-1.fc26.x86_64
python3-ordered-set-2.0.0-6.fc26.noarch
python3-appdirs-1.4.3-1.fc26.noarch
python3-rpm-4.13.0.1-7.fc26.x86_64
python3-beautifulsoup4-4.6.0-1.fc26.noarch
python2-pynacl-1.1.1-1.fc26.x86_64
python3-bind-9.11.1-2.P3.fc26.noarch
python2-libs-2.7.13-12.fc26.x86_64
python3-iscsi-initiator-utils-6.2.0.874-3.git86e8892.fc26.x86_64
python2-crypto-2.6.1-14.fc26.x86_64
python3-libcomps-0.1.8-3.fc26.x86_64
python3-packaging-16.8-4.fc26.noarch
python3-jsonschema-2.5.1-5.fc26.noarch
python-gssapi-1.2.0-5.fc26.x86_64
python3-magic-5.30-11.fc26.noarch
python2-gpg-1.8.0-12.fc26.x86_64
python3-ntplib-0.3.3-6.fc26.noarch
python3-pycurl-7.43.0-8.fc26.x86_64
boost-python-1.63.0-9.fc26.x86_64
python2-pip-9.0.1-9.fc26.noarch
python-IPy-0.81-18.fc26.noarch
python3-bytesize-0.11-1.fc26.x86_64
python3-raven-6.0.0-1.fc26.noarch
python2-requests-2.13.0-1.fc26.noarch
python2-decorator-4.0.11-2.fc26.noarch
python2-markupsafe-0.23-13.fc26.x86_64
python3-hawkey-0.11.1-1.fc26.x86_64
python3-olefile-0.44-2.fc26.noarch
python3-kickstart-2.35-2.fc26.noarch
libselinux-python-2.6-7.fc26.x86_64
python3-humanize-0.5.1-7.fc26.noarch
python-mako-1.0.6-3.fc26.noarch
python2-pygments-2.2.0-7.fc26.noarch
python3-cups-1.9.72-11.fc26.x86_64
python3-nose-1.3.7-13.fc26.noarch
python3-firewall-0.4.4.5-1.fc26.noarch
python2-sphinx-1.5.2-4.fc26.noarch
python3-rpm-macros-3-20.fc26.noarch
python2-rpm-macros-3-20.fc26.noarch
python3-zipstream-1.1.4-7.fc26.noarch
python3-html5lib-0.999-13.fc26.noarch
python2-typing-3.5.2.2-3.fc26.noarch
python2-bcrypt-3.1.3-1.fc26.x86_64
python3-requests-2.13.0-1.fc26.noarch
python-qt5-rpm-macros-5.8.1-4.fc26.noarch
python-urlgrabber-3.10.1-11.fc26.noarch
python3-cairo-1.10.0-20.fc26.x86_64
python3-pytz-2016.10-4.fc26.noarch
python3-ply-3.9-3.fc26.noarch
python3-gobject-base-3.24.1-1.fc26.x86_64
python3-pip-9.0.1-9.fc26.noarch
python2-libcomps-0.1.8-3.fc26.x86_64
python3-pyatspi-2.24.0-1.fc26.noarch
python2-pycurl-7.43.0-8.fc26.x86_64
python3-markupsafe-0.23-13.fc26.x86_64
python3-setuptools-36.2.0-2.fc26.noarch
python3-requests-ftp-0.3.1-6.fc26.noarch
python2-paramiko-2.2.1-1.fc26.noarch
python3-lxml-3.7.2-2.fc26.x86_64
python2-six-1.10.0-9.fc26.noarch
python2-sphinx-theme-alabaster-0.7.9-3.fc26.noarch
python-systemd-doc-234-1.fc26.x86_64
python2-rpm-4.13.0.1-7.fc26.x86_64
python3-inotify-0.9.6-8.fc26.noarch
python2-idna-2.5-1.fc26.noarch
python3-louis-2.6.2-9.fc26.noarch
python3-coverage-4.4.1-1.fc26.x86_64
python3-pid-2.1.1-3.fc26.noarch
python2-sphinx_rtd_theme-0.2.4-1.fc26.noarch
python-rhsm-certificates-1.20.2-1.fc26.x86_64
python2-packaging-16.8-4.fc26.noarch
python2-httplib2-0.10.3-2.fc26.noarch
python2-cffi-1.9.1-2.fc26.x86_64
python-ipaddress-1.0.16-4.fc26.noarch
python-tempita-0.5.1-15.fc26.noarch
python2-pygpgme-0.3-22.fc26.x86_64
dbus-python-1.2.4-6.fc26.x86_64
python2-pyOpenSSL-16.2.0-6.fc26.noarch
audit-libs-python3-2.8.1-1.fc26.x86_64
python3-pysocks-1.6.7-1.fc26.noarch
python2-whoosh-2.7.4-6.fc26.noarch
system-python-3.6.2-8.fc26.x86_64
python2-nose-1.3.7-13.fc26.noarch
libsemanage-python3-2.6-4.fc26.x86_64
policycoreutils-python-utils-2.6-6.fc26.x86_64
python2-devel-2.7.13-12.fc26.x86_64
[user@192 iptables]$

And compare to see what do you have in your system?! :doh:

_nobody_

zoeparman
4th November 2017, 09:18 AM
I've checked it, and I get the exact same output

nobody
5th November 2017, 05:17 AM
Seems, that this is your (mortal) problem... :doh:


[root@192 ~]# dnf install system-python
Last metadata expiration check: 0:16:17 ago on Sun 05 Nov 2017 04:44:41 AM CET.
Package system-python-3.6.2-8.fc26.x86_64 is already installed, skipping.
Dependencies resolved.
Nothing to do.
Complete!
[root@192 ~]# dnf remove system-python
Error:
Problem: The operation would result in removing the following protected packages: dnf
[root@192 ~]#

Well... Just throwing (around) brain storming! :D

_nobody_