PDA

View Full Version : [SOLVED] "rpm -q --scripts shadow" CLI command on Fedora26 returns nothing!



nobody
27th October 2017, 08:06 AM
Hello to Forum,

I successfully built Open Embedded YOCTO QEMU build with only one base layer in it: meta layer. Target qemux86-64 CLI transcript follows:


-----------------------
Build Configuration: |
-----------------------
DISTRO = nodistro
DISTRO_VERSION = nodistro.0
-----------------------
Layer Revisions: |
-----------------------
meta = master:3b413a80578caacd9a7f405f3c51a3921d78a60d

And I am able to run on the same target (qemux86-64):


root@qemux86-64:~# rpm -q --scripts shadow
postinstall scriptlet (using /bin/sh):
# shadow - postinst
if [ "x$D" != "x" ]; then
rootarg="--root $D"
else
rootarg=""
fi

pwconv $rootarg || exit 1
grpconv $rootarg || exit 1
[snip]

Now, on the Fedora 26 host (x86_64 platform), I have the following situation while running rpm -q --scripts shadow command (CLI transcript follows, as usual):


$ uname -r
4.13.8-200.fc26.x86_64
$ rpm -qa | grep shadow
shadow-utils-4.3.1-3.fc26.x86_64
[U][user@localhost ~]$ rpm -q --scripts shadow
package shadow is not installed
[user@localhost ~]$ rpm -q --scripts shadow-utils
[user@localhost ~]$

The same as root:


[root@localhost ~]# rpm -q --scripts shadow
package shadow is not installed
[U][root@localhost ~]# dnf install shadow
Last metadata expiration check: 0:18:52 ago on Fri 27 Oct 2017 08:44:08 AM CEST.
No match for argument: shadow
Error: Unable to find a match
[root@localhost ~]# dnf whatprovides shadow
Last metadata expiration check: 0:19:09 ago on Fri 27 Oct 2017 08:44:08 AM CEST.
Error: No Matches found
[root@localhost ~]#

I was, after all, surprised (expected the same/similar outcome). Any idea why this command on Fedora 26 host shows different results? :confused:

Thank you,
_nobody_

marko
28th October 2017, 06:23 PM
Yocto has a "shadow" package, Fedora does not

Fedora does have the shadow-utils and the "rpm -q --scripts shadow-utils" being nothing just shows it has no scriptlets

nobody
4th November 2017, 08:59 AM
Hello Marco (Polo),

Seems, that you are very correct! :C


[root@192 ~]# dnf install shadow-utils
Last metadata expiration check: 0:25:40 ago on Sat 04 Nov 2017 08:22:31 AM CET.
Package shadow-utils-2:4.3.1-3.fc26.x86_64 is already installed, skipping.
Dependencies resolved.
Nothing to do.
Complete!
[root@192 ~]# rpm -qa | grep shadow-utils
shadow-utils-4.3.1-3.fc26.x86_64
[root@192 ~]# rpm -q --scripts shadow-utils
[root@192 ~]#

Well, this thread is solved, although negatively! :D

_nobody_