View Full Version : Nvidia proprietary drivers F26 with OpenGL 32 bit

26th October 2017, 11:28 PM
Hello once again,

I'm having this strange issue with regards any 32 bits OpenGL application, where when I try to run the program I get Segmentation Fault with this backtrace (almost the same for all of them, guess they start to change about #14):

when trying to run steam

#0 0x00000000 in ?? ()
#1 0xf7c58dde in __pthread_once_slow () from /lib/libpthread.so.0
#2 0xf7281568 in ?? () from /lib/libGLX_nvidia.so.0
#3 0xf724966c in ?? () from /lib/libGLX_nvidia.so.0
#4 0xf7fe6400 in _dl_init () from /lib/ld-linux.so.2
#5 0xf7feb142 in dl_open_worker () from /lib/ld-linux.so.2
#6 0xf7bd3405 in _dl_catch_error () from /lib/libc.so.6
#7 0xf7fea539 in _dl_open () from /lib/ld-linux.so.2
#8 0xf7dedc05 in dlopen_doit () from /lib/libdl.so.2
#9 0xf7bd3405 in _dl_catch_error () from /lib/libc.so.6
#10 0xf7dee38e in _dlerror_run () from /lib/libdl.so.2
#11 0xf7dedc8e in dlopen@@GLIBC_2.1 () from /lib/libdl.so.2
#12 0xf738d869 in __glXLookupVendorByName () from /lib/libGLX.so.0
#13 0xf738ebf8 in __glXLookupVendorByScreen () from /lib/libGLX.so.0
#14 0xf7387ee6 in glXChooseVisual () from /lib/libGLX.so.0
#15 0x565a0827 in ?? ()
#16 0x565a6203 in CBaseLinuxUpdateUI::BaseCreateWindow() ()
#17 0x565a70ee in CXWindowsUpdateUI::BCreateWindow() ()
#18 0x56577420 in ?? ()
#19 0xf7ab82c3 in __libc_start_main () from /lib/libc.so.6
#20 0x5657aae9 in _start ()

I also tried Godot and two programs that I wrote, they work in 64 bits, but not when i compile for 32 bits.
ldd does not accuse any missing libs. Btw I have other PC that have this exact same config as mine, but without an Nvidia card, 32 works fine.

I'm assume that there is something wrong with the Nvidia drivers. Trophonix in GitHub tried the latest version of the drive an still the same.

Any Ideas? maybe a downgrade (I do not want to go through all the pain this will give me)

My specs (Fedora 26, Kernel 4.13.5, Nvidia 384.69)
Original git discusion: GitHub Issue (https://github.com/ValveSoftware/steam-for-linux/issues/5216)

27th October 2017, 10:55 AM
Duplicate of: https://www.forums.fedoraforum.org/showthread.php?t=315892 :doh:


29th October 2017, 01:03 AM
The other thread was deleted.

No luck with the new kernel 4.13.9-200. Any other ideas?

31st October 2017, 05:16 AM
just happened to me on my update, i got an old dell latitude with a nvs3100m nvidia card what i did was:
Downloaded proprietary driver from nvidia compatible with my card: mine was NVIDIA-Linux-x86_64-340.104.run
after that init 3 in terminal
cd to Downloads
sudo sh ./NVIDIA-Linux-x86_64-340.104.run --no-unified-memory
in terminal
it pretty much tells you that my chip doesn't support CUDA tools
install the v 32 bit let is jiggle your x files and after rebootb

31st October 2017, 06:11 AM
No luck with the new kernel 4.13.9-200. Any other ideas?

Please, try to run failsafe kernel, and see if this would work?! f YES, please, tell us which this kernel (uname -a) is?

In lot of occasions Nvidia drivers' developers are much slower (following kernel.org) than mainline kernel (kernel.org) developers, which are the fastest in changing the base/interfaces. :D


24th November 2017, 03:52 AM
Today I got the courage to deal with this issue once again.

And I managed to fix this issue, by reinstalling the Nvidia drives.
1. reboot at runlevel 3
2. run the Nvidia installer

This was caused because I did not install the 32 compatibility libs in the first time :doh:

Hey tanks for all the help!