PDA

View Full Version : F26 Kde goes "system is not ready for upgrade"



giampaolo44
22nd October 2017, 02:20 PM
Hello there :)

I am looking for some help on an upgrade from F25 kde spin to F26 kde as well.

Went through the recommended terminal procedure of downloading first (which apparently went well and completed its transaction tests successfully), and then rebooting but received the "system is not ready for upgrade" error message.

Searching around I found two different suggestions, i.e.
1) disable repos that were not ready, so after running
# dnf repolist and getting these results:

Failed to synchronize cache for repo 'snuxoll-morituri', disabilitazione in corso.
Failed to synchronize cache for repo 'mstuchli-Python3.5', disabilitazione in corso.
Ultima verifica della scadenza dei metadati: 0:36:30 fa il Sun Oct 22 13:03:46 2017.
id repo nome repo stato
adobe-linux-x86_64 Adobe Systems Incorporated 3
*fedora Fedora 25 - x86_64 51669
frafra-duperemove Copr repo for duperemove owned by frafra 5
google-chrome google-chrome 3
google-talkplugin google-talkplugin 1
mysql-connectors-community MySQL Connectors Community 33
mysql-tools-community MySQL Tools Community 17
mysql57-community MySQL 5.7 Community Server 100
rommon-telegram Copr repo for telegram owned by rommon 2
*rpmfusion-free RPM Fusion for Fedora 25 - Free 541
*rpmfusion-free-updates RPM Fusion for Fedora 25 - Free - Updates 259
*updates Fedora 25 - x86_64 - Updates 21822

I disabled the starred and unsyncronized ones. To no avail.

2) I then tried to run the reboot command with --allowerasing option, which was the second suggestion I could find, and it returned again the same initial error.

In the process I did not encounter any indication on what might interfere with the upgrade.

Any suggestion?

Cheers, and thanks in advance,
Giampaolo

donatom
22nd October 2017, 03:44 PM
It seems that rpmfusion is not ready to upgrade several files to fedora 26 (snuxoll-morituri and mstuchli-Python3.5). You could remove these two packages and then run the dnf upgrade to bring fedora up to the newest iteration. Then you could try to install these packages. When rpmfusion is ready, they will be installed (don't know if you can live without them in the meantime).

Alternatively you could retry the upgrade with the option "--nogpgcheck". I can't guarantee the success of using this option, but someone recommended it for a similar situation.

Here is the website:
https://forum.fedoraonline.it/viewtopic.php?id=24468

giampaolo44
22nd October 2017, 05:26 PM
Thanks Donato.

So you mean not just disabling the repos, but actually uninstalling the packages altogether?
(I'm not even sure which packages we are talking about, but I can probably try and figure them out)

donatom
22nd October 2017, 06:36 PM
(I'm not even sure which packages we are talking about, but I can probably try and figure them out)

Maybe I am confused but it seems like the following errors refer to packages -- or are they two of your repos?


Failed to synchronize cache for repo 'snuxoll-morituri', disabilitazione in corso.
Failed to synchronize cache for repo 'mstuchli-Python3.5', disabilitazione in corso.

Buona fortuna!

giampaolo44
22nd October 2017, 10:08 PM
Repos :) That message has been around for a while. I had disabled them, in any case, just to make sure, but nothing changed.

Grazie!