PDA

View Full Version : F26 Basic Desktop installs "successfully" but fails



db2
21st October 2017, 01:36 AM
F26 Desktop 64bit (and 32bit) netinstall.
Selected only Base Environment = Basic Desktop "X Window System with a choice of window manaager" No Add-ons selected.
The install completes with "Fedora is now successfully installed and ready for you to use".
Rebooting grub menu OK, graphical Fedora Logo at center OK, no login screen, and after about 10 seconds hangs perminently with black text screen and blinking cursor.

I tried on 3 different computers, all gave same result: Dell XPS13, Asus Q170M-C, and Asus 32 bit Intel laptop. However the same installation on VirturalBox results in a fully functional basic desktop system.

I have installed Fedora this way for many years and F26 is the first to fail in this manner.

nsnbm
22nd October 2017, 12:06 PM
If the installation is just basic plus X, then I guess the display manager is xdm. I would boot to runlevel 3 and check that the display manager is enabled and the link is present in /etc/systemd/system/display-manager.service. Possibly is if the same installation works in a VM. I suppose I'd install another display manager like lightdm to see if that worked.

db2
22nd October 2017, 11:18 PM
It looks like this install includes lightdm by default.

/etc/systemd/system/display-manager.service exists as sym link to /usr/lib/systemd/system/lightdm.service

I tried executing lightdm.

[root@localhost ~]# lightdm
(lightdm:829): GLib-GObject-CRITICAL**: g_object_unref: assertion 'G_IS_OBJECT (object)' failed

In F25 executing lightdm works without error.

nsnbm
23rd October 2017, 12:04 AM
If you plug "(lightdm:829): GLib-GObject-CRITICAL**: g_object_unref: assertion 'G_IS_OBJECT (object)' failed" into a search engine there's a bit of info to wade through but nothing that I could see that was exactly as you describe. There have been bugs with this output but upgrading apparently has resolved them, at least in Red Hat installations. lightdm has been updated but if your install was a netinstall, you may already have the latest lightdm. Perhaps check that one.

db2
23rd October 2017, 09:02 PM
I have found that for at least a year, net installs no longer provide all updates during installation. In this case the net install results in a non-functional F26 Workstation w/Basic Desktop until its updated. I had to boot to runlevel 3 in order to update the system. After updating the Basic Desktop now works.

nsnbm
24th October 2017, 04:01 AM
Thanks for that info on netinstall. Good that you got it going. Updating is a bit like nice new clean fuel, you often need it for optimal running.

AlexTheoto
25th October 2017, 07:34 PM
You can mark your thread as SOLVED from the 'Thread tools'