PDA

View Full Version : Swiss keyboard not working properly in installer



theking2
15th October 2017, 08:17 AM
I use the Swiss german legacy keyboard. In the installation programme the keys [] and {} are not working. These keys are accessed while pressing the Alt+Gr key.

lsatenstein
16th October 2017, 02:37 AM
Are you using Gnome 3.2x?
This is what I did to get rid of a bad bad GNOME key assignment.
I wrote a script that I set it up as a reminder to me, including the startup of the dconf-editor


#!/bin/bash
# Version 0.9
# ************************************************** **********************************
# This code (script) explains how to remove two key combinations that
# interfere with GNU APL when used with GNOME
# The problem manifests itself when trying to use the key located above the [tab]
and to the left of the [1]
# Without following the instructions herein, that [~ `] is unreachable.

# The explanation follows.
#------------------------
# Start the dconf-editor
# Follow the schema to /org/gnome/desktop/wm/keybindings/
# Scroll for switch-group
# The value before the change : ['<Super>Above_Tab','<Alt>Above_Tab']
# Note that "switch-groups" has two setttings,
# Remove the right most setting ",<Alt>'Above_Tab'" by deleting from right to left.

# While you are erasing the characters, from right to left, you have a
# highlight to indicate an error indication.
# That highlight will disappear when you erase the comma following the first argument.
# Your net result should be ['<Super>Above_Tab']

# You have to do the same for the shift-groups-backward

# The backwords setting is next one immediately following #switch-group-backward
# Remove the ,'<shift><Alt>Above_Tab'

#************************************************* ********************************
clear
cat $0
sleep 5
/usr/bin/dconf-editor

What you need to do is to study the keyboard assignments within
/org/gnome/desktop/wm/keybindings/ todetermine what to modify.

If the command line interface is wrong, then visit
usr/share/X11/xkb/symbols
Search for your keyboard layout and review the layouts. One or perhaps two will be responding to what you require.

theking2
16th October 2017, 10:36 PM
Are you using Gnome 3.2x?
This is what I did to get rid of a bad bad GNOME key assignment.
I wrote a script that I set it up as a reminder to me, including the startup of the dconf-editor


#!/bin/bash
# Version 0.9
# ************************************************** **********************************
# This code (script) explains how to remove two key combinations that
# interfere with GNU APL when used with GNOME
# The problem manifests itself when trying to use the key located above the [tab]
and to the left of the [1]
# Without following the instructions herein, that [~ `] is unreachable.

# The explanation follows.
#------------------------
# Start the dconf-editor
# Follow the schema to /org/gnome/desktop/wm/keybindings/
# Scroll for switch-group
# The value before the change : ['<Super>Above_Tab','<Alt>Above_Tab']
# Note that "switch-groups" has two setttings,
# Remove the right most setting ",<Alt>'Above_Tab'" by deleting from right to left.

# While you are erasing the characters, from right to left, you have a
# highlight to indicate an error indication.
# That highlight will disappear when you erase the comma following the first argument.
# Your net result should be ['<Super>Above_Tab']

# You have to do the same for the shift-groups-backward

# The backwords setting is next one immediately following #switch-group-backward
# Remove the ,'<shift><Alt>Above_Tab'

#************************************************* ********************************
clear
cat $0
sleep 5
/usr/bin/dconf-editor

What you need to do is to study the keyboard assignments within
/org/gnome/desktop/wm/keybindings/ todetermine what to modify.

If the command line interface is wrong, then visit
usr/share/X11/xkb/symbols
Search for your keyboard layout and review the layouts. One or perhaps two will be responding to what you require.

In the live environment I'm not sure what version I'm using. The keyboard that works fine outside the live is called Swiss-german legacy and is working awesomely. The one in the installation does not react very well on [] and {} keys.

Is there a place to report this bug?

lsatenstein
18th October 2017, 03:58 AM
https://bugzilla.redhat.com/

sign up, then search for your bug. If noone else has reported it, then do so.

theking2
18th October 2017, 07:48 AM
https://bugzilla.redhat.com/show_bug.cgi?id=1503439