PDA

View Full Version : libreoffice in read only mode



thick0
15th October 2017, 04:28 AM
Hi,

I am running Fedora 26 and I recently noticed that all files opened by libreoffice were in read only mode. Eventually I realised I had just booted into a new kernel (4.13.4-200.fc26.x86_64). I reverted back to the old kernel (4.12.14-300.fc26.x86_64) and all was well.

Now along comes another kernel (4.13.5-200.fc26.x86_64) and the same problem occurs all files read only. So I am back to 4.12.14. As my version of LO was quite old I downloaded the latest (5.4.2.2) and the problem persists.

My documents are stored on my samba server so I checked a file on my PC. No problem. I am really not sure where the root of the problem lies a combination of Fedora, LO & Samba?. The last SMB update is dated Sep 24. I can't see any messages in systemctl or the samba logs on both computers (host and server). Has anyone experienced anything similar? I would like to report the bug but which bugzilla? I am tempted to say Fedora.

Cheers

thick0
2nd November 2017, 05:27 AM
Hi,

I logged this one with redhat

https://bugzilla.redhat.com/show_bug.cgi?id=1506472

The solution suggested


So a solution until SMB3 POSIX extensions are available would be to modify your mount options to force SMB1.Unfortunately eludes me at the moment. Searches to force SMB1 typically result in how to force SMB2/3 or how to disable SMB1. I tried to use the knowledge gained and modify smb.conf
min protocol = SMB1
max protocol = SMB1
However my guess work was wrong
[tim@Havana ~]$ testparm /etc/samba/smb.conf
Load smb config files from /etc/samba/smb.conf
rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)
WARNING: Ignoring invalid value 'SMB1' for parameter 'min protocol'
Error loading services. Any suggestions on how to to modify mount options to force SMB1?

Cheers