PDA

View Full Version : H.264 (High Profile) decoder



theking2
14th October 2017, 10:48 PM
Hi
Attempts to play h264 fail with the message H.264 (High Profile) decoder is required.
Open h264 is installed:

# dnf install openh264
Last metadata expiration check: 0:06:08 ago on Sat 14 Oct 2017 23:42:00 CEST.
Package openh264-1.6.0-5.fc26.x86_64 is already installed, skipping.
Dependencies resolved.
Nothing to do.
Complete!

Cylon1972
15th October 2017, 11:36 AM
dnf install h264enc

Dutchy
15th October 2017, 06:59 PM
"Q. Which profiles of H.264 will be supported?
A: The initial code has the baseline profile. We look forward to working with the open source community to add high profile and others."

flyingdutchman
16th October 2017, 12:25 PM
Have you tried the VideoLAN X264 codec?
https://www.videolan.org/developers/x264.html

I have been using this one for several years.

theking2
16th October 2017, 10:32 PM
dnf install h264enc

No package h264enc available.
Error: Unable to find a match

---------- Post added at 09:32 PM ---------- Previous post was at 09:30 PM ----------


Have you tried the VideoLAN X264 codec?
https://www.videolan.org/developers/x264.html

I have been using this one for several years.

I have not "tried" these but from the link it is not entirely clear how to try them. Isn't there a dnf, yum or "Software" install thingy?

Cylon1972
17th October 2017, 03:11 PM
have you enabled the rpmfusion repo?


dnf search h264enc
Laatste metadata-expiratie-check: 6 days, 5:58:57 geleden op wo 11 okt 2017 10:11:49 CEST.
================================================== ============================= Naam Komt exact overeen met: h264enc ================================================== ==============================
h264enc.noarch : An interactive menu-driven frontend for mencoder

flyingdutchman
17th October 2017, 05:23 PM
"I have not "tried" these but from the link it is not entirely clear how to try them. Isn't there a dnf, yum or "Software" install thingy? "
You click the Download box and save the tar ball.
Untar it and read the README and INSTALL files.
In general, it will be a simple matter of "./configure;make;make install".

simon2000
17th October 2017, 06:19 PM
tried ./configure

got
Found no assembler
Minimum version is nasm-2.13
If you really want to compile without asm, configure with --disable-asm.

tried install dev86.x86_64

and still got the same message
Found no assembler
Minimum version is nasm-2.13
If you really want to compile without asm, configure with --disable-asm.

simon2000
17th October 2017, 06:44 PM
nasm.x86_64 installed, that solved the issue,
then make ran successfully