PDA

View Full Version : prevent network on boot



feddy
9th October 2017, 03:26 PM
Hi,

since I updated to fed 26 on my laptop something has messed up and boot gets stuck because there is no wireless network connection ( there never was ).

40s into to boot I can not get any further.

I have done the init=/bin/bash boot option to get a root console so how can I disable network service being run on boot so that I can at least boot the computer?


TIA

lightman47
9th October 2017, 06:26 PM
I wonder if, for whatever reason, it's trying to mount a shared drive somewhere. I am thinking maybe some old remnant from a previous setup ... ??? What does /etc/fstab look like?

feddy
9th October 2017, 07:19 PM
Thanks for the reply.

The "earlier setup" was yesterday and it worked perfectly. Never had any remote mounts or anything.

fstab is one line.


I need to be able to find out whether this is a kernel module or a service starting and stop it doing so at boot time.

It' s probably network manager.

It seems a lot of devs have the idea that everyone in the world is permanently connected to reliable network and no one does anything not requiring the internet on a computer.

There was a bug in Thunderbird which got ignored for 14 years because the devs thought the messages would never show up "in reality" and it was just theoretical bug. Again based on the idea that networks have 100% uptime.

Maybe a first step would be take networking out of the boot runlevel.


so how can I disable network service being run on boot so that I can at least boot the computer?

lightman47
9th October 2017, 07:24 PM
Hmm - if you will never be connecting to a network, you could always disable NetworkManager I suppose ...


sudo systemctl disable NetworkManager

Then, if you opt to connect at a future date you could then just enable it again. Also make sure the network service isn't running - it's 'one or the other' but some folk have found both NetworkManager and network running on their machines.

feddy
9th October 2017, 07:39 PM
thanks.

I did not say I would never be connecting. There is no wifi here and I do NOT want it to be a prerequite of being able to boot them damned machine.

I will need wifi to be available later. Initially I need to be able to boot !

I already tried systemclt but from the root emergency console it does not work.


Failed to connect to bus No such file or directlory

:(


If is definately NetworkManage causing the problems

Starting Hold until boot process finished up ...
Starting NetworkNamage Script Dispatcher Service ....


It is just after that that I get all the 'link isn not ready ' crap happening.

Ah, I've just found something else a few lines earlier:

Starting NetworkManager Wait Online


So it does look like some fool thinks the computer has to get online before I even a login screen.

BTW the update was done using a wired connection but plugging that in does not prevent it locking up on boot.

feddy
9th October 2017, 09:13 PM
OK, I did manage to log into a secondary console in between it flipping back to the boot console every 3s .

I was able to stop and disable NM but it did not help.

Still at about the 39s mark, it gets into the same loop.

last line output :

ip-set : protocol 6

two lines up

arp/ip/iptables is not long available by default.

Maybe it is the firewall causing problems.

Ah! I find lxdm is showing with new process id each time. So it looks like this is what is spawning and failing at 3s intervals.

systemstl stop lxdm

has regained some sanity. It is no long jumping around. Maybe now I can get some work done on fixing this.

feddy
10th October 2017, 08:46 AM
OK, I've found the problem.

Nothing to do with networking.

I had added a file to /etc/X11/xorg.conf.d to re-enable synaptic tapping. I had used single quotes instead of double quotes around strings.

That caused a systax error and X faited to start WITHOUT ANYTHING SHOWING ON THE CONSOLE.

lxdm will respawn every time X closes EVEN IF FAILS TO START OR CRASHES. thus the infuriating switch back to the primary console.

The fact that the output from X was getting swallowed left the impression it was a previous service which was locking up the system and gave no indication it was X.


systemctl stop lxdm
systemctl disable lxdm



Having done that and tried startx manually I got output from X which identified the problem instantly.

The root of the bug here is that lxdm is swallowing the output which should have shown on the console and allowed me to directly see where and what the problem was.

This is why I hate GUI login managers and stupid screen blanking graphics during boot time.

This system no longer has a GUI login and boots to console like all my other boxes.

What a run-around