PDA

View Full Version : Gnome-RDP not working aftert upgrade to F26



SHLelieveld
5th October 2017, 09:46 AM
Hello all,

Thanks for taking a look.
Recently I've updates my Fedora 25 version to 26, I use gnome-RDP a lot to access multiple systems on our Network. But since the upgrade to F26 the gnome-RDP gui interface does not work anymore.

in the LOG tab in gnome-RDP I get this:
Information: Creating process for rdesktop -u lelies -p "<password>" -k en-us -g 2133x1200 -a 32 -z -x l -5 -r sound:local 172.23.5.251
Error: No process is associated with this object.
Verbose: System.InvalidOperationException: No process is associated with this object.
at System.Diagnostics.Process.EnsureState (System.Diagnostics.Process+State state) [0x0001e] in <f8255d9ef0594d18ae2c0d97286b9a80>:0
at System.Diagnostics.Process.EnsureState (System.Diagnostics.Process+State state) [0x00037] in <f8255d9ef0594d18ae2c0d97286b9a80>:0
at System.Diagnostics.Process.GetProcessHandle (System.Int32 access, System.Boolean throwIfExited) [0x00089] in <f8255d9ef0594d18ae2c0d97286b9a80>:0
at System.Diagnostics.Process.GetProcessHandle (System.Int32 access) [0x00000] in <f8255d9ef0594d18ae2c0d97286b9a80>:0
at System.Diagnostics.Process.WaitForInputIdle (System.Int32 milliseconds) [0x00002] in <f8255d9ef0594d18ae2c0d97286b9a80>:0
at System.Diagnostics.Process.WaitForInputIdle () [0x00000] in <f8255d9ef0594d18ae2c0d97286b9a80>:0
at (wrapper remoting-invoke-with-check) System.Diagnostics.Process:WaitForInputIdle ()
at GnomeRDP.SessionHost.WorkerThread () [0x0005c] in <794978738ed449a4b4f09b95276c2dc4>:0


But when I use a manual CLI command to use rdesktop: rdesktop -u <user> -p <password> -k en-us -g 2133x1200 -a 24 -x l <IP> &
That works just fine.

Is there anything I can check/do/re-install/remove/change to get it working again?

SHLelieveld
11th October 2017, 02:17 PM
nobody has that same issue? Or does noone have a proper fix for this...? :)

alphacrucis
11th October 2017, 11:41 PM
Default for f26 is wayland. Maybe the app doesn't work with wayland. Try selecting Xorg session on the gnome login screen

SHLelieveld
12th October 2017, 09:45 AM
It was working fine in Wayland under Fedora25 and in testing with the Wayland under Fedora24 (I did not ran in Wayland in fedora24 in production, but tested it non the less).

So no step further...

SHLelieveld
3rd November 2017, 02:11 PM
Apperently I'm the only one.... not sure how why, but I cannot find anyone with the same issues.

Going to re-install my machine soon again and we will see...

lsatenstein
4th November 2017, 12:12 AM
Official Fedora 27 was approved for distribution. Target date is November 7, some 4 days hence.

SHLelieveld
2nd May 2018, 02:54 PM
Hi All, the problem persisted in Fedora 27 for me, But as there was no going forward and I expected to get a new machine soon at the time I did not do anything.
Now on a new Machine it didn't work in Fedora 27, today updated it to Fedora 28 and still a no go...

I think I miss some dependancies, or I have some preferences wrong where this error pops up.
Weird is that on Fedora 25 it worked fine, moved to Fedora 26 (back then) and it was broken, and still is...
Also tried a clean start no copy over from any previous preferences and that also did not help.

Please anyone an idea what to try?