View Full Version : [SOLVED] F26:LiveCD: Can't enter user password at login

24th September 2017, 10:23 AM
Booting livecd created with official tools stops at login. One can type in password in the field, but pressing Enter have no effect

1) installed livecd-tools and kickstarts
2) Used livecd-creator with fedora-live-kde.ks (without any changes) in /usr/share/spinkickstarts
3) Used livecd-iso-to-disk to burn the iso to a usb

a) Booting on several machines give same result
b) booting stops at the screen with session selection, keyboard selection, reboot/off buttons, time on the left and LiveSystemUser on the right part of the screen. Already here LiveCd normally should not ask for a password (if user has not set it) and should auto-login
c) Typing password shows black dots/circles, but pressing Enter seem have not effect at all (no even minor blink on the screen).
d) If I type ctrl+alt+F2 it enters into text mode and I can "debug" a bit
dmesg shows few red lines (at the end)
10.505022 kvm: disabled by bios
101.454222 ata2 exception Emask ...
/var/log/boot.log is all green
/var/log/messages does not seem to contain something strange at first sight


Burning official iso from the fedora site boots of course on all machines.

Also tried to generate iso with small changes in the KDE ks file. Added multiple users with passwords or not. All users appear at boot and one can choose them and type passwords, but none go through.

Tried to generate iso from fedora-live-workstation.ks (Gnome instead of KDE), it does not even boot ("Error loading operating system") while mbr, partition, etc. are ok.

Tried to burn the iso with dd instead of livecd-iso-to-disk. Same effect.

System is updated to latest. We use cache with livecd-creator.

Conclusions and need for help
Generally, if livecd stops at login page, this means there was an error in one of the scripts in the .ks file or the livecd-iso-to-disk fails. Btw, in favor of the second, if one add "--extra-kernel-args ..." while using livecd-iso-to-disk, this has no effect and does not change boot parameters.

Inspiration is fading away so don't thesitate to spark suggestions...

24th September 2017, 10:48 AM
... Update

Burning a Gnome iso generated by myself from fedora-live-workstation but with dd instead of livecd-iso-to-disk (dd if=./F26gnome.iso of=/dev/sdb) does boot Gnome livecd.
- generation of gnome iso is probably good, but burning it with livecd-iso-to-disk fails (compared to dd)
- for kde both burning methods lead to the login issue described

Booting kde livecd, then alt+f2 and debugging further
Running journalctl has few red lines
page 30 iscsid ..
page 38 systemd ...
page 43 systemd-udev ..
page 49 smartd ...
line 1489 sddm [1057] Unable to find autologin session ... (That could be it - KDE window manager don't have autologin session)

24th September 2017, 10:58 AM
booting kde livecd (from official fedora-live-kde), then ctrl+alt+f2 to the session and had a look at /etc/sddm.conf


... Everything else is commented including General,Wayland,X11

24th September 2017, 12:36 PM
Booted produced livecd, same issue, Ctrl+alt+f2, logged in, several users present, passwords ok, so something with window manager

Directory /usr/share/xsessions does not contain plasma.desktop file ... is this normal for boot?

Copied plasma.desktop from another computer to /usr/share/xsessions and to /var/lib/sddm/.desktop (default I assume). Ctrl+Alt+F1 and back to F2. Then systemctl status sddm tries to open /var/lib/sddm/.desktop and says "Failed to find XDG session type".

Also /usr/share/sddm/themes contain only 02-fedora and not 01-breeze-fedora, but the issue is with sessions it seems. Any ideas (not necessarily solutions)?

Will try to disable autologin ...

24th September 2017, 01:56 PM
Removed everything in .ks file related autologin and forced the theme to 02-fedora.
Livecd now boots to login screen with username and password, but none of the users go through.
Ctrl+Alt+f2 and "systemctl status sddm" gives "Invalid session /var/lib/sddm/.desktop" so I assume that one can exclude autologin and theme directions.

The focus here is thus on the sessions (or session file).....
Don't hesitate to tell if I should go to another forum :-)

26th September 2017, 08:20 AM
Have found a solution - obviously there was a bug in the official .ks file (or handling of those instructions by livecd-tools).
Will post solution in a day (this way also you can still guess what was the problem).

Package plasma-workspace was missing. Adding it to .ks file explicitly solves the problem. It is a bug because group @kde-workspace should install it.