PDA

View Full Version : apache2



oldopensuseuser
17th September 2017, 03:46 PM
Greetings !!

I'm new in fedora, I come from opensuse which I abandonned due to the leap project I experienced lot of disappointment that costs me too much to trust it again.

I'm a professor in informatical sciences with little experience in system administration.

let me figure out the different challenges:

tomorrow I will give courses to my students with a computer messed up with leap 42.2 :{
i need to have those services working, in URGENCE ^^

samba, apache2

For now samba seems to work but i can't mount any shares using mount.cifs nore fstab entries as I used for years now.
My students have an account on my samba server called rasalgethi
They need this disk space to work.

I got


Enter root's password:
DEZORDI.WORLD
\\SIRIUS sirius (Linux octocore)
\\SIRIUS\imprimante HP LaserJet 6L Foomatic/ljet4 (recommended)
\\SIRIUS\IPC$ IPC Service (sirius (Linux octocore))
\\SIRIUS\netbeans projets
\\SIRIUS\UTILITAIRES scripts shell
\\SIRIUS\ELEVES boulot école
\\SIRIUS\LDF Dub
\\SIRIUS\DUB travaux
\\SIRIUS\LIBRARIES Latest updates
\\SIRIUS\TRAVAUX Cyrius exemples
\\SIRIUS\MARKET Répertoire foure-tout
\\SIRIUS\print$ Printer Drivers
\\RASALGETHI rasalgethi (Linux)
\\ANTARES ANTARES (PDC)
\\ANTARES\IPC$ IPC Service (ANTARES (PDC))
\\ANTARES\Cours synchro
\\ANTARES\utilitaires scripts
\\ANTARES\mp3 zique
\\ANTARES\isos isos
\\ANTARES\prodz LDF prodz
\\ANTARES\dvds jeux
\\ANTARES\netbeans projets antares
\\ANTARES\disque externe antares Disque externe
\\ANTARES\corrections Corrections
\\ANTARES\installz programmes
\\ANTARES\users All users
\\ANTARES\exercices Exercices
\\ANTARES\exemples Exemples


Saying there is no shares available... with the exact same configuration used for years with opensuse 13.2.
As leap 42.2 messed up my system on rasalgethi I switched to fedora.

They also need the apache2 server to access the different referentials shared.

I tried to install apache2 as I used for years: dnf search apache2 then install (zypper search apache2 then install)

I had the surprise to discover that there was no apache2 package.
Wher could I found an apache2 package working on fedora ?

Thank you ^^

oldopensuseuser
17th September 2017, 04:48 PM
the samba issue was solved by disabling selinux and opening the firewall ports...

in the other hand, still have no web server installed, seeking on apache org site.

remi
25th September 2017, 10:13 AM
> in the other hand, still have no web server installed, seeking on apache org site.

Package name is "httpd"


P.S.: apache2 is some other distro is a bad name, Apache is a Foundation hosting various projects, HTTPD Web Server is one of those projects