View Full Version : [SOLVED] Installing Armory 0.96 on Fedora 26

15th September 2017, 08:54 AM
I am trying to install armory from the source. The issue that I have is when I run ./configure, I get the following error:

configure: error: missing lrelease in path, make sure qt4-linguist-tools is installed

The following are however installed

Package qt-devel-1:4.8.7-28.fc26.x86_64 is already installed.
Package qt-doc-1:4.8.7-28.fc26.noarch is already installed.
Package qt-creator-4.2.2-6.fc26.x86_64 is already installed.

I have tried editing the configure.ac file (https://github.com/goatpig/BitcoinArmory/blob/master/configure.ac#L86) but that did not help.

Any ideas?:confused:

15th September 2017, 11:33 AM
lrelease binary in Fedora is called lrelease-qt4 so maybe that is causing this issue. Try to append Qt binary directory to path.

export PATH=$PATH:/usr/lib/qt4/bin/

15th September 2017, 09:16 PM
Alas no joy. Did not work

16th September 2017, 12:25 AM
Got it working using

sudo ln -s /usr/bin/lrelease-qt4 /usr/bin/lrelease