View Full Version : Boot problems, Live CD throws a time-out error and more...

7th September 2017, 08:00 PM
The problem is big and complex.
First of all, I had Windows 10 and installed Fedora on top of it. I have only one hard drive, so I had no choice but to install them on the same drive. During the boot I would simply choose system from boot options. I replaced W10 with W7 and this is where fun started.
After reinstall Fedora was no longer in boot options. I tried to repair this via Fedora netinstall (rescue a Fedora system), but at certain stage (about 6 seconds after start) it just stops and waits until time-out error comes, then time-out scripts activate and console shows up. Same problem with Live CD. I'm not very confident with this interface, so I didn't try to dig in there.
After that I tried to use Boot-Repair. I downloaded Boot-Repair-Disk on USB drive, booted from it and tried different things. When launching recommended repair, it gives me window with this text: Please enable a repository containing the [grub-efi-amd64-signed] packages in the software sources of Fedora release 26 (Twenty (mapper/fedora-root). Then try again. Some people said that Boot-Repair can't solve the Fedora problem because of it is oriented on Ubuntu, uses apt-get and deb packages, but developer said it can repair Fedora. At least it gave full information about my hard drive and partitions on it. Info is stored here: http://paste.ubuntu.com/25485355/
The question is what is going on? I can't use Live CD, I can't reinstall GRUB2, Boot-Repair doesn't work properly.
Humbly awaiting for help -.-

17th September 2017, 04:05 PM
Maybe Windows broke your Linux. I'm not surprised...
Try to understand what these timeout errors are for and try to see if your Linux is alive.
Do you use the same installation media you used when you first installed fedora?