PDA

View Full Version : [SOLVED] UEFI entries dissapeared from boot options



Bittler
7th September 2017, 10:42 AM
I am dual-booting Windows 10 and Fedora 26, both using uefi.

After I reset my bios/uefi however both previously available boot options, "windows boot manager" (which started windows) and Fedora (which started grub, allowing the choice between windows and fedora), disappeared from my mainboard's boot options. The drives themselves are still selectable, but selecting one gives me nothing but a black screen.

A quick double-check with the live cd confirmed the data on hdds remains the same, the single efi partition contains a boot, a fedora and a windows folder.

I needed fast access to my Windows system and tried the Windows repair option from the Windows installation cd. It said it didn't work, but it did. The Windows entry reappeared in my boot options and it starts up fine, got my work done, alas Fedora remains inaccessible.

Here is how my partitions are set up, if it helps:
Disk 0:
Windows Recovery, EFI (created by windows, mounted as /boot/efi in fedora), Windows, Boot (mounted as /boot), Swap, Home (mounted as /home)
Disk 1:
root (mounted as /)

UEFI is enabled in the mainboard, it does not support secure boot. Overall I have not even the slightest idea what is going on, I tried basically every single boot setting in the bios without success.

I am sure I could just reinstall fedora, but I would be happy avoiding that as well as understanding what is going on. Thanks for your help.

edit: I was able to recreate the missing entry with the help of the live-cd and efibootmgr

# efibootmgr --create --disk /dev/sdc2 --part 3 --label "Grub" --loader \\EFI\\Boot\\bootx64.efidid the trick for me.

N8tiv
7th September 2017, 06:06 PM
When you want to get into Fedora, maybe… Disable "UEFI", put your machine into "Legacy Mode"…

And when you want to get back into Windows, reenable it?

antikythera
7th September 2017, 07:13 PM
no, don't start switching between UEFI and legacy mode it is not necessary and will cause further issues