PDA

View Full Version : [SOLVED] Fedora crashes during install



mac25
5th September 2017, 11:39 PM
Hello,

I'm trying to install Fedora 26 on an Acer Aspire 64bits UEFI , dual boot with Windows 10.
Everything goes fine until, about 60% through installing the software it just crashes and the computer turns off.
I have tried this several times, with Fedora 26 and also Fedora 25, both on USB and DVD, always exactly the same result, exactly at the same point during the install.
I assume it is some sort of issue with my hardware and the Fedora install system, but I can't understand what.
I have installed Fedora 26 once before on another computer i686 and had no problem whatsoever.
I'm not a Fedora user, but reasonably experienced with Linux.
I'm trying to help a friend who needs to learn fedora in order to apply for a job.

Thanks.

lsatenstein
6th September 2017, 02:18 AM
Is your computer well ventilated? To shut off in the middle of an update indicates blocked cooling vents or fan blades full of lint.
The upgrade is quite cpu intensive, and a blocked laptop vent appears to indicate why it shuts down half way.

Check the above out. Try vacuuming each of the laptop ducts and retry after a bit of dust removal.

mac25
6th September 2017, 02:33 AM
Thanks for your answer but I don't think that's the case, because the computer never does that while using it with Windows for hours on end and also because on several Fedora install trials, both fro USB and DVD is crashed precisely at the same time, about 60% through the install of the software.

antikythera
6th September 2017, 10:14 AM
verify the installation media is not corrupt. use the test this media option from the grub boot menu to make sure it is okay to use. also only use 64-bit x86_64 media for a dual boot 64-bit machine.

also make sure the notebook is running from mains power and try to keep it awake by moving the cursor or pressing a key from time to time. while i've never seen a computer shutdown during installation like that the screen saver can kick in around 60% if you are installing from optical media.

mac25
7th September 2017, 01:14 AM
I think the issue is with the Anaconda installer and either Acer Aspire or the Windows 10 setup.
Besides Fedora I have tried other Fedora-based distros like Centos and Scientific Linux, and they crashed exactly at the same point, even when I used this laptop in Legacy mode and installed the distro from USB to USB, without touching the main HD.
Always crashed at the same point, which I assume is when Anaconda tries to set the boot up device and gets in trouble with the partitioning scheme.
Eventually, out of frustration in the wee hours of morning, I installed Debian on this machine, no problem whatsoever, even if it is not what my friend really needs to learn, but it is Linux at least.

antikythera
7th September 2017, 08:17 AM
anaconda sets the bootloader after software installation reaches 100%. what i'd be tempted to do is clear the linux partitions, and create 1 large NTFS partition. then run a sector by sector chkdsk (using the switch /R)from windows to look for bad sectors on the drive you are installing to.


CHKDSK filename]] [/F] [/R] [/X] [/I] [/C] [/L[:size]]

The options and switches for Check Disk are used as follows:
volume Sets the volume to work with
path/filename Specifies files to check for fragmentation (FAT16 and FAT32 only)
/F Fixes errors on the disk
/V Displays the full path and name of every file on the disk (FAT16 and FAT32); displays cleanup messages if any (NTFS)
/R Locates bad sectors and recovers readable information (implies /F)
/X Forces the volume to dismount first if necessary (implies /F)
/I Performs a minimum check of index entries (NTFS only)
/C Skips checking of cycles within the folder structure (NTFS only)
/L:size Sets the log file size (NTFS only)
/B Re-evaluates bad clusters on the volume (NTFS only; implies /R)

N8tiv
7th September 2017, 10:38 AM
Try this:

Boot into the OS that you normally have been using…
Get into your bios, Before your machine starts to load your operating system.
Look around in your options and disable UEFI, "Legacy Mode"…
Then try the installation again…

Hope this works,

Rob

mac25
9th September 2017, 06:14 AM
Hello,
I finally was able to install Fedora after disabling UEFI in the BIOS menu and booting in Legacy mode.
I believe I had tried that before, but obviously I had missed something along the way.
There is now the issue of booting Windows from Grub, but I'll post this under another topic.

Thanks!