PDA

View Full Version : Fedsetupguides, Fedy



jeb3121
5th September 2017, 04:49 AM
Hi again,

Having my fresh 26 WS I went to the Fed Set-Up Guides and installed the Gnome Tweak Tools.

Then I went to:
"Fedy - Works with both F25 and F26. A modular and scriptable utility to install codecs and proprietary software, add & manage repos and much more, also saves downloaded files. This will download the script. You then have to open a terminal, "cd" to your downloaded location. Next, "su" as root and type "chmod +x fedy-installer", followed by "./fedy-installer" . That should install Fedy and the necessary repos. Finally, exit root temporarily and type "fedy" to give you a GUI with plenty of handy codecs."

From my terminal:

[jeb@localhost ~]$ cd
jeb@localhost ~]$ su
Password:
[root@localhost jeb]# chmod +x fedy-installer ./fedy-installer
chmod: cannot access 'fedy-installer': No such file or directory
chmod: cannot access './fedy-installer': No such file or directory
[root@localhost jeb]#

Perhaps the problem is my interpretation of the sequence in the description as exemplified by my terminal entries.

jeb

thom12
5th September 2017, 09:19 AM
Just click on "Fedy" on "Fedora Set-Up Guides" page.
When you do so, you're getting to:
https://www.folkswithhats.org/


To install Fedy in Fedora, open a Terminal and run the following command:
sudo sh -c 'curl https://www.folkswithhats.org/installer | bash'


It installs folkswithhats repo and fedy and ...

Find Fedy in desktop menu ...

Good luck.

bob
5th September 2017, 11:08 AM
Thanks thom12. And Jeb, yeah those instructions were initially provided by Fedy back when F25 was released and need to be updated a bit now. I'll change it.

glennzo
5th September 2017, 11:31 AM
Works for both 25 and 26. Just use the link.

jeb3121
24th September 2017, 07:37 AM
Just click on "Fedy" on "Fedora Set-Up Guides" page.
When you do so, you're getting to:
https://www.folkswithhats.org/


It installs folkswithhats repo and fedy and ...

Find Fedy in desktop menu ...

Good luck.

Hi thom,

I went thru the Install Fedy and thinking everything must be OK, there were items online to be filed.

Trying downloaded videos, the message on the black screen was Need MPEG-4AAC decoder and H.264(Main Profile) decoder.


Finding Fedy on the desktop and going thru all of headings, I found nothing relating to decoders.

I assume Youtube is involved; what needs to be done? :confused:

Hopefully,
jeb

thom12
25th September 2017, 01:18 PM
To install more media progs (fx mplayer) install rpmfusion repos.

dnf -y install --nogpgcheck \
http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-$(rpm -E %fedora).noarch.rpm \
http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-$(rpm -E %fedora).noarch.rpm

May be you install mplayer, xine, vlc.

Fx:
dnf install mplayer mplayer-gui mencoder
dnf install xine xine-lib-extras xine-lib-extras-freeworld
dnf install vlc

codecs:
dnf install faac # faac for MPEG-4AAC
dnf install x264 x264-libs # for H264

I prefer to install handish.
If you use it, Fedy installs gstreamer packages. Your choice.

jeb3121
25th September 2017, 02:22 PM
To install more media progs (fx mplayer) install rpmfusion repos.

dnf -y install --nogpgcheck \
http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-$(rpm -E %fedora).noarch.rpm \
http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-$(rpm -E %fedora).noarch.rpm

May be you install mplayer, xine, vlc.

Fx:
dnf install mplayer mplayer-gui mencoder
dnf install xine xine-lib-extras xine-lib-extras-freeworld
dnf install vlc

codecs:
dnf install faac # faac for MPEG-4AAC
dnf install x264 x264-libs # for H264

I prefer to install BTW. Your choice.

Hi Thom, thanks for your response.

I entered: dnf -y install --nogpgcheck \
and got:
usage: dnf install [-c [config file]] [-q] [-v] [--version]
[--installroot [path]] [--nodocs] [--noplugins]
[--enableplugin [plugin]] [--disableplugin [plugin]]
[--releasever RELEASEVER] [--setopt SETOPTS]
[--skip-broken] [-h] [--allowerasing] [-b] [-C]
[-R [minutes]] [-d [debug level]] [--debugsolver]
[--showduplicates] [-e ERRORLEVEL] [--obsoletes]
[--rpmverbosity [debug level name]] [-y] [--assumeno]
[--enablerepo [repo]] [--disablerepo [repo] | --repo
[repo]] [-x [package]] [--disableexcludes [repo]]
[--repofrompath [repo,path]] [--noautoremove]
[--nogpgcheck] [--color COLOR] [--refresh] [-4] [-6]
[--destdir DESTDIR] [--downloadonly] [--bugfix]
[--enhancement] [--newpackage] [--security]
[--advisory ADVISORY] [--bzs BUGZILLA] [--cves CVES]
[--sec-severity {Critical,Important,Moderate,Low}]
[--forcearch ARCH]
PACKAGE [PACKAGE ...]
dnf install: error: the following arguments are required: PACKAGE

I'm at a loss; apparently there's a prior step I missed.

BTW, my video needs are basic; I just play downloads. Which would you recommend for that purpose, handish or gstreamer?

jeb

bob
25th September 2017, 03:20 PM
OOPS! My error! Apparently when adding the Set-Up Guides for F26, I dropped the instructions for RPMFusion. If you'll go back to the Set-Up Guides, I've added the link now. Hope that will assist you.

thom12
25th September 2017, 05:52 PM
Should have written that it is a one-liner:


dnf -y install --nogpgcheck http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-$(rpm -E %fedora).noarch.rpm http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-$(rpm -E %fedora).noarch.rpm

Got to copy and past it it in one step to a command line.

As su or sudo:

sudo dnf ...

If a one-liner is broken into parts, "\" is used at the end of each part to avoid a newline.

One can copy and paste these 3 lines to the command line and bash reads it as a one-liner (because of the "\" at the end of each part-line)
Sorry.

thom12
25th September 2017, 05:58 PM
I recommend vlc. Plays almost everything.

Install it handish ("by hand") - without using Fedy.

Use dnf on the command line instead.

jeb3121
26th September 2017, 09:23 AM
[SIZE="2"][SIZE="1"][SIZE="1"]
Should have written that it is a one-liner:


dnf -y install --nogpgcheck http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-$(rpm -E %fedora).noarch.rpm http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-$(rpm -E %fedora).noarch.rpm

Got to copy and past it it in one step to a command line.

As su or sudo:

sudo dnf ...

If a one-liner is broken into parts, " " is used at the end of each part to avoid a newline.

One can copy and paste these 3 lines to the command line and bash reads it as a one-liner (because of the " " at the end of each part-line)
Sorry.

No big deal Thom,

I broke it down to:
dnf-y install --nogpgcheck http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-$ \
(rpm -E %fedora).noarch.rpm http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-$ \
(rpm -E %fedora).noarch.rpm \
and twice got:
bash: syntax error near unexpected token `('
[root@localhost jeb]#

After the 1st time I shifted the line breaks so that the parentheses were complete on the same line, no luck.

Can I assume that "dnf vlc" will be successful after the above problem is solved?

Again, thanks for your help,
jeb

thom12
26th September 2017, 12:06 PM
To install rpmfusion repos go to:

https://rpmfusion.org/Configuration


Command Line Setup using rpm

To enable access to both the free and the nonfree repository use the following command:

Fedora 22 and later:


sudo dnf install https://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-$(rpm -E %fedora).noarch.rpm https://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-$(rpm -E %fedora).noarch.rpm

You broke it the wrong way.
--The line-continuation will fail if you have whitespace (spaces or tab characters) after the backslash and before the newline. With no such whitespace, the code works fine for me. No whitespace after the backslash!

--Don't insert whitespaces into the command where they don't belong - bash remarks an error because of the <space> ahead of the backslash. Bash expands the code to
...release-$ (rpm...
But the original code is
...release-$(rpm...

--Maybe you noticed that the backslash in "\" did not show up in your post in normal text mode. I suppose you have to write
"\\" if you are in normal text mode.

In my post i wrote literally <space><backslash>.
The <space> is the space ahead of each https...
...nstall https... and
...noarch.rpm https...

The code in your post

I broke it down to:
dnf-y install --nogpgcheck http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-$ \
(rpm -E %fedora).noarch.rpm http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-$ \
(rpm -E %fedora).noarch.rpm \
and twice got:
bash: syntax error near unexpected token `('
can easily be corrected by removing the space ahead of the backslash and the last space and backslash: there is no breakpoint here. And of course you should add sudo ... And a <space> between dnf and "-y" ...
Your code should look like this:

sudo dnf -y install --nogpgcheck http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-$\
(rpm -E %fedora).noarch.rpm http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-$\
(rpm -E %fedora).noarch.rpm

If you brake a long commandline it is only a backslash that informs bash about a line-continuation. If you add a leading <space> to the backslash, bash adds it to the code. At this place there is no <space> in the original code. And thus bash immediately finds out that this is a coding-syntax error.

To avoid show-up problems in normal text mode use wrapping-mode for code.
It is the "#" symbol: "Wrap
tags around selected text".
In the wrapped text you can write as on the command line: [CODE]"\"

You could verify the code draft by using echo "<your code>" and you see how it will be expanded.


echo "\
sudo dnf -y install --nogpgcheck http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-$\
(rpm -E %fedora).noarch.rpm http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-$\
(rpm -E %fedora).noarch.rpm"

gives you:


sudo dnf -y install --nogpgcheck http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-26.noarch.rpm http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-26.noarch.rpm

And this is what we expected.

Sorry that it's so tricky.
Let's go back to your main problem instead.


Please copy and paste the installation command from rpmfusion.org to a terminal/console at the prompt in one piece to avoid further mistakes.
When you enter a long command into the Terminal window that you found on the web or in a document, you can save yourself some time by easily copying and pasting the command at the prompt.

Position the cursor at the beginning of the text you want to cut/copy.
Select the whole text you want to copy and press Ctrl-c.
Move the cursor the prompt and paste the selected text by pressing Ctrl-v.
The text is pasted.

Press enter. (I assume that you did setup sudo once ...)

Rpmfusion repos should install flawlessly now.

Then install vlc.


sudo dnf install vlc

jeb3121
30th September 2017, 08:37 AM
QUOTE
thom12
Re: Fedsetupguides, Fedy
To install rpmfusion repos go to:

https://rpmfusion.org/Configuration
Quote:
Command Line Setup using rpm

To enable access to both the free and the nonfree repository use the following command:

Fedora 22 and later:

Code:

sudo dnf install https://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-$(rpm -E %fedora).noarch.rpm https://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-$(rpm -E %fedora).noarch.rpm

You broke it the wrong way.
--The line-continuation will fail if you have whitespace (spaces or tab characters) after the backslash and before the newline. With no such whitespace, the code works fine for me. No whitespace after the backslash!

--Don't insert whitespaces into the command where they don't belong - bash remarks an error because of the <space> ahead of the backslash. Bash expands the code to
Code:

...release-$ (rpm...

But the original code is
Code:

...release-$(rpm...

--Maybe you noticed that the backslash in "" did not show up in your post in normal text mode. I suppose you have to write
Code:

""

if you are in normal text mode.

In my post i wrote literally <space><backslash>.
The <space> is the space ahead of each https...
Code:

...nstall https...

and
Code:

...noarch.rpm https...

The code in your post
Quote:
I broke it down to:
dnf-y install --nogpgcheck http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-$ \
(rpm -E %fedora).noarch.rpm http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-$ \
(rpm -E %fedora).noarch.rpm \
and twice got:
bash: syntax error near unexpected token `('
can easily be corrected by removing the space ahead of the backslash and the last space and backslash: there is no breakpoint here. And of course you should add sudo ... And a <space> between dnf and "-y" ...
Your code should look like this:
Quote:
sudo dnf -y install --nogpgcheck http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-$\
(rpm -E %fedora).noarch.rpm http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-$\
(rpm -E %fedora).noarch.rpm
If you brake a long commandline it is only a backslash that informs bash about a line-continuation. If you add a leading <space> to the backslash, bash adds it to the code. At this place there is no <space> in the original code. And thus bash immediately finds out that this is a coding-syntax error.

To avoid show-up problems in normal text mode use wrapping-mode for code.
It is the "#" symbol: "Wrap [CODE] tags around selected text".
In the wrapped text you can write as on the command line:
Code:

"\"

You could verify the code draft by using echo "<your code>" and you see how it will be expanded.

Quote:
echo "\
sudo dnf -y install --nogpgcheck http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-$\
(rpm -E %fedora).noarch.rpm http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-$\
(rpm -E %fedora).noarch.rpm"
gives you:

Code:

sudo dnf -y install --nogpgcheck http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-26.noarch.rpm http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-26.noarch.rpm

And this is what we expected.

Sorry that it's so tricky.
Let's go back to your main problem instead.


Please copy and paste the installation command from rpmfusion.org to a terminal/console at the prompt in one piece to avoid further mistakes.
When you enter a long command into the Terminal window that you found on the web or in a document, you can save yourself some time by easily copying and pasting the command at the prompt.

Position the cursor at the beginning of the text you want to cut/copy.
Select the whole text you want to copy and press Ctrl-c.
Move the cursor the prompt and paste the selected text by pressing Ctrl-v.
The text is pasted.

Press enter. (I assume that you did setup sudo once ...)

Rpmfusion repos should install flawlessly now.

Then install vlc.

Code:

sudo dnf install vlc
Quote

thom12
Re: Fedsetupguides, Fedy
To install rpmfusion repos go to:

https://rpmfusion.org/Configuration
Quote:
Command Line Setup using rpm

To enable access to both the free and the nonfree repository use the following command:

Fedora 22 and later:

Code:

sudo dnf install https://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-$(rpm -E %fedora).noarch.rpm https://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-$(rpm -E %fedora).noarch.rpm

You broke it the wrong way.
--The line-continuation will fail if you have whitespace (spaces or tab characters) after the backslash and before the newline. With no such whitespace, the code works fine for me. No whitespace after the backslash!

--Don't insert whitespaces into the command where they don't belong - bash remarks an error because of the <space> ahead of the backslash. Bash expands the code to
Code:

...release-$ (rpm...

But the original code is
Code:

...release-$(rpm...

--Maybe you noticed that the backslash in "\" did not show up in your post in normal text mode. I suppose you have to write
Code:

"\\"

if you are in normal text mode.

In my post i wrote literally <space><backslash>.
The <space> is the space ahead of each https...
Code:

...nstall https...

and
Code:

...noarch.rpm https...

The code in your post
Quote:
I broke it down to:
dnf-y install --nogpgcheck http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-$ \
(rpm -E %fedora).noarch.rpm http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-$ \
(rpm -E %fedora).noarch.rpm \
and twice got:
bash: syntax error near unexpected token `('
can easily be corrected by removing the space ahead of the backslash and the last space and backslash: there is no breakpoint here. And of course you should add sudo ... And a <space> between dnf and "-y" ...
Your code should look like this:
Quote:
sudo dnf -y install --nogpgcheck http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-$\
(rpm -E %fedora).noarch.rpm http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-$\
(rpm -E %fedora).noarch.rpm
If you brake a long commandline it is only a backslash that informs bash about a line-continuation. If you add a leading <space> to the backslash, bash adds it to the code. At this place there is no <space> in the original code. And thus bash immediately finds out that this is a coding-syntax error.

To avoid show-up problems in normal text mode use wrapping-mode for code.
It is the "#" symbol: "Wrap [CODE] tags around selected text".
In the wrapped text you can write as on the command line:
Code:

"\"

You could verify the code draft by using echo "<your code>" and you see how it will be expanded.

Quote:
echo "\
sudo dnf -y install --nogpgcheck http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-$\
(rpm -E %fedora).noarch.rpm http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-$\
(rpm -E %fedora).noarch.rpm"
gives you:

Code:

sudo dnf -y install --nogpgcheck http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-26.noarch.rpm http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-26.noarch.rpm

And this is what we expected.

Sorry that it's so tricky.
Let's go back to your main problem instead.


Please copy and paste the installation command from rpmfusion.org to a terminal/console at the prompt in one piece to avoid further mistakes.
When you enter a long command into the Terminal window that you found on the web or in a document, you can save yourself some time by easily copying and pasting the command at the prompt.

Position the cursor at the beginning of the text you want to cut/copy.
Select the whole text you want to copy and press Ctrl-c.
Move the cursor the prompt and paste the selected text by pressing Ctrl-v.
The text is pasted.

Press enter. (I assume that you did setup sudo once ...)

Rpmfusion repos should install flawlessly now.

Then install vlc.

Code:

sudo dnf install vlc
Quote

Hi Thom,

I ran the full-length sudo dnf install https://download1--- successfully and sudo dnf install vlc.

Vlc showed a warning after d/l packages: “ /var/cache/dnf/rpmfusion-free-updates-326d941b38a63deb/packages/vlc-3.0.0-0.35.git20170922.fc26.x86_64.rpm: Header V4 RSA/SHA1 Signature, key ID 9690e4af: NOKEY”, but at the end did say: “Complete!”

Checking via video .flv and .mp4 files; with each I got got popup stating MPEG-4AAC and H.264 codecs were needed.

I then attempted:
[jeb@localhost ~]$ dnf install MPEG-4AAC
Error: This command has to be run under the root user.
[jeb@localhost ~]$ su
Password:
[root@localhost jeb]# dnf install MPEG-4AAC
Last metadata expiration check: 2:35:17 ago on Sat 30 Sep 2017 09:24:47 AM +07.
No package MPEG-4AAC available.
Error: Unable to find a match
[root@localhost jeb]#
[root@localhost jeb]# dnf install H.264
Last metadata expiration check: 0:09:27 ago on Sat 30 Sep 2017 12:26:47 PM +07.
No package H.264 available.
Error: Unable to find a match
[root@localhost jeb]#

Remembering your comment about checking Fedy on the desktop, I went there. I came up empty after looking at every subset; nothing relating to codecs.

Next step? 8~)
jeb

Thanks for the coding tips(saved).

thom12
30th September 2017, 11:43 AM
As alreadfy stated in Post #6 you could install:


sudo dnf install faac faad2 faad2-libs x264 x264-libs h264enc ffmpeg

where faac is for encoding to MPEG-4AAC
where faad2 is for decoding MPEG-4AAC
where x264 gets you codecs for h.264
To get info about the packages:
fx
dnf info h264enc

dnf info <packagename>

h264 is a proprietary patented video codec. So you to have purchase the rights. But luckily there is opensource codec/package x264 to play this.:)

You may also be interested in what gives you info's about a media-file

dnf info mediainfo
sudo dnf install mediainfo-gui mediainfo



Mplayer

dnf info mplayer
If you want to install mplayer you may install as well:
codecs:
read this: https://www.mjmwired.net/resources/mjm-fedora-f19.html#binarycodecs

Then in a terminal/console:

cd <yourusername>/Downloads
or

cd $HOME/Downloads

wget -c http://www.mplayerhq.hu/MPlayer/releases/codecs/all-20110131.tar.bz2

sudo mkdir -p /usr/lib/codecs

sudo tar -jxvf all-20110131.tar.bz2 --strip-components 1 -C /usr/lib/codecs/

Hope you can watch media/films ...

jeb3121
1st October 2017, 03:41 AM
As alreadfy stated in Post #6 you could install:


sudo dnf install faac faad2 faad2-libs x264 x264-libs h264enc ffmpeg

where faac is for encoding to MPEG-4AAC
where faad2 is for decoding MPEG-4AAC
where x264 gets you codecs for h.264
To get info about the packages:
fx
dnf info h264enc

dnf info <packagename>

h264 is a proprietary patented video codec. So you to have purchase the rights. But luckily there is opensource codec/package x264 to play this.:)

You may also be interested in what gives you info's about a media-file

dnf info mediainfo
sudo dnf install mediainfo-gui mediainfo



Mplayer

dnf info mplayer
If you want to install mplayer you may install as well:
codecs:
read this: https://www.mjmwired.net/resources/mjm-fedora-f19.html#binarycodecs

Then in a terminal/console:

cd <yourusername>/Downloads
or

cd $HOME/Downloads

wget -c http://www.mplayerhq.hu/MPlayer/releases/codecs/all-20110131.tar.bz2

sudo mkdir -p /usr/lib/codecs

sudo tar -jxvf all-20110131.tar.bz2 --strip-components 1 -C /usr/lib/codecs/

Hope you can watch media/films ...

Hi Thom

Taking your advice, I went to command line with:
sudo dnf install faac faad2 faad2-libs x264 x264-libs h264enc ffmpeg

[jeb@localhost ~]$ sudo dnf install faac faad2 faad2-libs x264 x264-libs h264enc ffmpeg
[sudo] password for jeb:
Last metadata expiration check: 1:20:34 ago on Sun 01 Oct 2017 06:43:47 AM +07.
Package faad2-libs-1:2.7-9.fc26.x86_64 is already installed, skipping.
Package x264-libs-0.148-20.20170519gitd32d7bf.fc26.x86_64 is already installed, skipping.
Dependencies resolved.
================================================== =========================================
Package Arch Version Repository Size
================================================== =========================================
Installing:
faac x86_64 1.28-7.fc26 rpmfusion-nonfree 85 k
faad2 x86_64 1:2.7-9.fc26 rpmfusion-free 46 k
ffmpeg x86_64 3.3.4-1.fc26 rpmfusion-free-updates 1.5 M
h264enc noarch 1:10.4.7-2.fc26 rpmfusion-free 135 k
x264 x86_64 0.148-20.20170519gitd32d7bf.fc26 rpmfusion-free 1.1 M
Installing dependencies:
libavdevice x86_64 3.3.4-1.fc26 rpmfusion-free-updates 85 k
libbs2b x86_64 3.1.0-17.fc26 fedora 27 k
libmp4v2 x86_64 2.1.0-0.9.trunkREV507.fc26 fedora 441 k
librtmp x86_64 2.4-8.20160224.gitfa8646d.fc26 rpmfusion-free 76 k
mencoder x86_64 1.3.0-9.fc26 rpmfusion-free 865 k
mplayer-common x86_64 1.3.0-9.fc26 rpmfusion-free 1.2 M
openal-soft x86_64 1.17.2-3.fc26 fedora 335 k

Transaction Summary
================================================== =========================================
Install 12 Packages

Total download size: 5.9 M
Installed size: 12 M
Is this ok [y/N]: y
Downloading Packages:
(1/12): faad2-2.7-9.fc26.x86_64.rpm 5.9 kB/s | 46 kB 00:07
(2/12): h264enc-10.4.7-2.fc26.noarch.rpm 16 kB/s | 135 kB 00:08
(3/12): libbs2b-3.1.0-17.fc26.x86_64.rpm 108 kB/s | 27 kB 00:00
(4/12): x264-0.148-20.20170519gitd32d7bf.fc26.x86_64.rpm 106 kB/s | 1.1 MB 00:10
(5/12): librtmp-2.4-8.20160224.gitfa8646d.fc26.x86_64.rpm 12 kB/s | 76 kB 00:06
(6/12): mencoder-1.3.0-9.fc26.x86_64.rpm 104 kB/s | 865 kB 00:08
(7/12): libmp4v2-2.1.0-0.9.trunkREV507.fc26.x86_64.rpm 1.7 MB/s | 441 kB 00:00
(8/12): faac-1.28-7.fc26.x86_64.rpm 39 kB/s | 85 kB 00:02
(9/12): libavdevice-3.3.4-1.fc26.x86_64.rpm 141 kB/s | 85 kB 00:00
(10/12): openal-soft-1.17.2-3.fc26.x86_64.rpm 3.6 MB/s | 335 kB 00:00
(11/12): ffmpeg-3.3.4-1.fc26.x86_64.rpm 583 kB/s | 1.5 MB 00:02
(12/12): mplayer-common-1.3.0-9.fc26.x86_64.rpm 126 kB/s | 1.2 MB 00:09
-------------------------------------------------------------------------------------------
Total 246 kB/s | 5.9 MB 00:24
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
Preparing : 1/1
Installing : openal-soft-1.17.2-3.fc26.x86_64 1/12
Running scriptlet: openal-soft-1.17.2-3.fc26.x86_64 1/12
Installing : libavdevice-3.3.4-1.fc26.x86_64 2/12
Running scriptlet: libavdevice-3.3.4-1.fc26.x86_64 2/12
Installing : libmp4v2-2.1.0-0.9.trunkREV507.fc26.x86_64 3/12
Running scriptlet: libmp4v2-2.1.0-0.9.trunkREV507.fc26.x86_64 3/12
Installing : mplayer-common-1.3.0-9.fc26.x86_64 4/12
Installing : librtmp-2.4-8.20160224.gitfa8646d.fc26.x86_64 5/12
Running scriptlet: librtmp-2.4-8.20160224.gitfa8646d.fc26.x86_64 5/12
Installing : libbs2b-3.1.0-17.fc26.x86_64 6/12
Running scriptlet: libbs2b-3.1.0-17.fc26.x86_64 6/12
Installing : mencoder-1.3.0-9.fc26.x86_64 7/12
Installing : h264enc-1:10.4.7-2.fc26.noarch 8/12
Installing : faac-1.28-7.fc26.x86_64 9/12
Running scriptlet: faac-1.28-7.fc26.x86_64 9/12
Installing : ffmpeg-3.3.4-1.fc26.x86_64 10/12
Installing : x264-0.148-20.20170519gitd32d7bf.fc26.x86_64 11/12
Installing : faad2-1:2.7-9.fc26.x86_64 12/12
Running scriptlet: faad2-1:2.7-9.fc26.x86_64 12/12
Verifying : faad2-1:2.7-9.fc26.x86_64 1/12
Verifying : x264-0.148-20.20170519gitd32d7bf.fc26.x86_64 2/12
Verifying : h264enc-1:10.4.7-2.fc26.noarch 3/12
Verifying : mencoder-1.3.0-9.fc26.x86_64 4/12
Verifying : libbs2b-3.1.0-17.fc26.x86_64 5/12
Verifying : librtmp-2.4-8.20160224.gitfa8646d.fc26.x86_64 6/12
Verifying : mplayer-common-1.3.0-9.fc26.x86_64 7/12
Verifying : faac-1.28-7.fc26.x86_64 8/12
Verifying : libmp4v2-2.1.0-0.9.trunkREV507.fc26.x86_64 9/12
Verifying : ffmpeg-3.3.4-1.fc26.x86_64 10/12
Verifying : libavdevice-3.3.4-1.fc26.x86_64 11/12
Verifying : openal-soft-1.17.2-3.fc26.x86_64 12/12

Installed:
faac.x86_64 1.28-7.fc26 faad2.x86_64 1:2.7-9.fc26
ffmpeg.x86_64 3.3.4-1.fc26 h264enc.noarch 1:10.4.7-2.fc26
x264.x86_64 0.148-20.20170519gitd32d7bf.fc26 libavdevice.x86_64 3.3.4-1.fc26
libbs2b.x86_64 3.1.0-17.fc26 libmp4v2.x86_64 2.1.0-0.9.trunkREV507.fc26
librtmp.x86_64 2.4-8.20160224.gitfa8646d.fc26 mencoder.x86_64 1.3.0-9.fc26
mplayer-common.x86_64 1.3.0-9.fc26 openal-soft.x86_64 1.17.2-3.fc26

Complete!

Attempting .MP4s from 2 different sources the popup still says MPEG=4AAC and H.264 are not installed.

However .flv changed the popup to MPEG-1 Layer 3 and Ou2 VP6/Flash not installed.

My impression was x264 avoided the proprietary problem.

Copy-paste is certainly a time-saver, but I’m at a loss. :confused:

jeb

thom12
1st October 2017, 05:45 AM
Try to install gstreamer1-libav, phonon-backend-gstreamer, phonon-backend-vlc.

sudo dnf install gstreamer1-libav, phonon-backend-gstreamer, phonon-backend-vlc


Testing that H.264 format works

Access the following page to see if H.264 is enabled: Youtube HTML5 video test (http://youtube.com/html5)
You can test some test videos from this site: HTML5 test videos
(http://www.quirksmode.org/html5/tests/video.html)

thom12
1st October 2017, 06:26 AM
If your problem is flash-player related:


sudo rpm -ivh http://linuxdownload.adobe.com/adobe-release/adobe-release-x86_64-1.0-1.noarch.rpm
sudo rpm --import /etc/pki/rpm-gpg/RPM-GPG-KEY-adobe-linux
sudo dnf install flash-plugin

Does your hardware allow to play h.264 and MPEG=4AAC ?

thom12
1st October 2017, 12:21 PM
Please try to download the following video to your $HOME/Downloads directory.

https://www.quirksmode.org/html5/tests/video.html
...
H.264/MP4
https://www.quirksmode.org/html5/videos/big_buck_bunny.mp4

Go to $HOME/Downloads.

wget -c https://www.quirksmode.org/html5/videos/big_buck_bunny.mp4

Right click (right mouse button) on the file, "open with" and you see the applications you can open the video file with.

--> choose Vlc Media Player

Does the file open?

jeb3121
2nd October 2017, 09:57 AM
Please try to download the following video to your $HOME/Downloads directory.

https://www.quirksmode.org/html5/tests/video.html
...
H.264/MP4
https://www.quirksmode.org/html5/videos/big_buck_bunny.mp4

Go to $HOME/Downloads.

wget -c https://www.quirksmode.org/html5/videos/big_buck_bunny.mp4

Right click (right mouse button) on the file, "open with" and you see the applications you can open the video file with.

--> choose Vlc Media Player

Does the file open?

Hi Thom
Received your Saturday post and off I went:

[jeb@localhost ~]$ sudo dnf install gstreamer1-libav, phonon-backend-gstreamer, phonon-backend-vlc
[sudo] password for jeb:
Last metadata expiration check: 0:04:54 ago on Mon 02 Oct 2017 10:17:31 AM +07.
No package gstreamer1-libav, available.
No package phonon-backend-gstreamer, available.
Error: Unable to find a match

Then going here: Youtube HTML5 video test (http://youtube.com/html5)
HTMLVideoElement
H.264
WebM VP8
Media Source Extensions
MSE & H.264
MSE & WebM VP9
The HTML5 player is currently used when possible.
All 7 have a checkmark. I assume Yes

Then here: (http://www.quirksmode.org/html5/tests/video.html)

H.264/MP4 played thru but this showed at top
<video controls>
<source src="../videos/big_buck_bunny.mp4" type="video/mp4">
<p>Your browser does not support H.264/MP4.</p>
</video>
Both WebM and Ogg/Theora played thru as well.
​​​​​​​Then your Sunday post:

I couldn’t place:
wget -c https://www.quirksmode.org/html5/videos/big_buck_bunny.mp4
into Home/d/ls but I found:
https://www.quirksmode.org/html5/tests/video.html

in which I found:
HTML5 tests – video:
This page tests the <video> tag for various OSs.
For H.264/MP4, FF 4.0b11 says NO

??????????

One item:
I don’t have a problem with video or music(also .mp4) online, only when I try to play my files.

jeb

thom12
2nd October 2017, 12:17 PM
What do you mean by "I couldn't place:" ?

In your home directory there should exist a subdirectory "Downloads".
I suggest that you download the file to this dir.

Open terminal/console and enter on the command line:

cd $HOME/Downloads

Have you installed wget? If not, do:

sudo dnf install wget

On the command line do:

wget -c https://www.quirksmode.org/html5/videos/big_buck_bunny.mp4
"-c" tells wget to download the file to the actual/current directory.

I choose this video to test your installation. Because it should open with VLC and VLC should play it.

Open your file browser (dolphin, nautilus, whatever, ...)
Then go to <your home directory>/Downloads.
It's a directory in your Home directory where downloads use to be saved.
Find the downloaded file big_buck_bunny.mp4, right click, "open with", choose VLC.

Does the downloaded file (downloaded to your harddisk) play ?

I'm NOT talking about your browser, whether your browser plays it.
You already verified your browser installation on https://www.quirksmode.org/html5/tests/video.html.
On this page ONLY your browser is tested.
NOT the applications on your computer.

Therefor I want you to test the application installation on your computer by downloading a file to your harddisk and trying to open/play it.

Does the downloaded file (downloaded to your harddisk) play with VLC?
When you right click on that file in your filebrowser what does the right click menu show?
It should list you some possible apps to open the file with.

jeb3121
2nd October 2017, 02:55 PM
What do you mean by "I couldn't place:" ?

In your home directory there should exist a subdirectory "Downloads".
I suggest that you download the file to this dir.

Open terminal/console and enter on the command line:

cd $HOME/Downloads

Have you installed wget? If not, do:

sudo dnf install wget

On the command line do:

wget -c https://www.quirksmode.org/html5/videos/big_buck_bunny.mp4
"-c" tells wget to download the file to the actual/current directory.

I choose this video to test your installation. Because it should open with VLC and VLC should play it.

Open your file browser (dolphin, nautilus, whatever, ...)
Then go to <your home directory>/Downloads.
It's a directory in your Home directory where downloads use to be saved.
Find the downloaded file big_buck_bunny.mp4, right click, "open with", choose VLC.

Does the downloaded file (downloaded to your harddisk) play ?

I'm NOT talking about your browser, whether your browser plays it.
You already verified your browser installation on https://www.quirksmode.org/html5/tests/video.html.
On this page ONLY your browser is tested.
NOT the applications on your computer.

Therefor I want you to test the application installation on your computer by downloading a file to your harddisk and trying to open/play it.

Does the downloaded file (downloaded to your harddisk) play with VLC?
When you right click on that file in your filebrowser what does the right click menu show?
It should list you some possible apps to open the file with.

Hi Thom,

I missed: cd $HOME/Downloads

Following thru the rest of your post brings up both music and video; HURRAH!!!

One final possibility: can I set VLC as automatic w/o having to choose it as an extra, right-click step in opening the file?

With or without this last question I really appreciate your time, knowledge and effort.

Thanks again, :dance:
jeb

bob
2nd October 2017, 11:27 PM
Settings > Details > Default Applications might work for you.

jeb3121
3rd October 2017, 03:47 AM
Settings > Details > Default Applications might work for you.

Hi Bob,

Just clicking on the file to start it would be really nice; how would I go about setting a default app?

jeb

BTW, thanks for updating the Set-up Guides. :)--

bob
3rd October 2017, 09:41 AM
What I was mentioning is that you should find a drop-box there for "videos" and you should be able to click "vlc media player" to be the default application to open them. If it's not listed, try rebooting and see if it appears as an option.

thom12
3rd October 2017, 12:23 PM
For KDE Desktop.

way 1:
right click on the file to play
--> properties --> Filetype options --> Application preference order
move VLC on the first line.

way 2:
(as Bob wrote)

If KDE desktop is installed.
https://userbase.kde.org/Category:Configuration
https://userbase.kde.org/System_Settings/File_Associations
https://userbase.kde.org/System_Settings/File_Associations/en
https://userbase.kde.org/File:Settings-file-associations.png

System settings --> Application --> File associations --> Known Types --> ">video"
click on the ">" ahead of "video"
A list of different video types pops up.
fx click on mp4 --> move VLC on the first line.
fx click on x-flv --> move VLC on the first line.
And so on with every video file type you like.
Last but not least "Apply". Close System settings.
Watch your video.

Be aware of what you do - it's at your own risk.