View Full Version : [SOLVED] Fedora 26 is missing dvb-core/dvb-frontends/em28xx

29th August 2017, 11:32 AM

after upgrding from F25 to F26 ( 4.12.8-300.fc26.x86 ) i noticed that /lib/modules/4.12.8-300.fc26.x86_64/kernel/drivers/media/dvb-core/ is empty, some goes for dvb-frontend, with the exception of drx39xyj. my usb dvb adapers driver, em28xx, seems gone too.

Any reason why it has been removed?


29th August 2017, 02:43 PM
$ ls /lib/modules/4.12.8-200.fc25.x86_64/kernel/drivers/media/dvb-*

a8293.ko.xz dibx000_common.ko.xz mb86a20s.ko.xz stv0367.ko.xz
af9013.ko.xz drx39xyj mn88472.ko.xz stv0900.ko.xz
af9033.ko.xz drxd.ko.xz mn88473.ko.xz stv090x.ko.xz
as102_fe.ko.xz drxk.ko.xz mt312.ko.xz stv6110.ko.xz
ascot2e.ko.xz ds3000.ko.xz mt352.ko.xz stv6110x.ko.xz
atbm8830.ko.xz dvb-pll.ko.xz nxt200x.ko.xz tc90522.ko.xz
au8522_common.ko.xz ec100.ko.xz nxt6000.ko.xz tda10021.ko.xz
au8522_decoder.ko.xz gp8psk-fe.ko.xz or51132.ko.xz tda10023.ko.xz
au8522_dig.ko.xz helene.ko.xz or51211.ko.xz tda10048.ko.xz
bcm3510.ko.xz horus3a.ko.xz rtl2830.ko.xz tda1004x.ko.xz
cx22700.ko.xz isl6405.ko.xz rtl2832.ko.xz tda10071.ko.xz
cx22702.ko.xz isl6421.ko.xz s5h1409.ko.xz tda10086.ko.xz
cx24110.ko.xz isl6423.ko.xz s5h1411.ko.xz tda18271c2dd.ko.xz
cx24113.ko.xz itd1000.ko.xz s5h1420.ko.xz tda665x.ko.xz
cx24116.ko.xz ix2505v.ko.xz s921.ko.xz tda8083.ko.xz
cx24117.ko.xz l64781.ko.xz si2165.ko.xz tda8261.ko.xz
cx24120.ko.xz lg2160.ko.xz si2168.ko.xz tda826x.ko.xz
cx24123.ko.xz lgdt3305.ko.xz si21xx.ko.xz ts2020.ko.xz
cxd2820r.ko.xz lgdt3306a.ko.xz sp2.ko.xz tua6100.ko.xz
cxd2841er.ko.xz lgdt330x.ko.xz sp8870.ko.xz ves1820.ko.xz
dib0070.ko.xz lgs8gxx.ko.xz sp887x.ko.xz ves1x93.ko.xz
dib0090.ko.xz lnbh25.ko.xz stb0899.ko.xz zd1301_demod.ko.xz
dib3000mb.ko.xz lnbp21.ko.xz stb6000.ko.xz zl10036.ko.xz
dib3000mc.ko.xz lnbp22.ko.xz stb6100.ko.xz zl10039.ko.xz
dib7000m.ko.xz m88ds3103.ko.xz stv0288.ko.xz zl10353.ko.xz
dib7000p.ko.xz m88rs2000.ko.xz stv0297.ko.xz
dib8000.ko.xz mb86a16.ko.xz stv0299.ko.xz

What does "rpm -qV kernel-modules" says?

Also verify that you have that package installed.

29th August 2017, 02:49 PM
Thanks, seems kernel-modules for my kernel version was not installed.
"dnf update kernel-modules" fixed it.

29th August 2017, 02:58 PM
Hmm, that seems strange, I am wondering if update to F26 finished successfully or was maybe interrupted.