PDA

View Full Version : facing problem to update fedora 26 via dnf



papai
27th August 2017, 10:55 PM
Hi,

I was upgraded my fedora 24 to fedora 26 via dnf. the up-gradation process was successful, but after up-gradation, dnf become unable to update the new version.

"dnf upgrade" command returning a error message:

Error: Failed to synchronize cache for repo 'updates' :confused:

kindly help me !!!!

Thanks in advance.

AlexTheoto
28th August 2017, 09:48 AM
Check if the repositories are updated with the command

dnf repolist

papai
30th August 2017, 09:50 PM
Thanks for your suggestion.

in reply to "dnf repolist" command, I am getting the same error: "Error: Failed to synchronize cache for repo 'updates' "

again seek help !!!

antikythera
30th August 2017, 10:24 PM
try

dnf clean all
dnf distro-sync

papai
31st August 2017, 09:34 PM
dnf distro-sync output:

Error: Failed to synchronize cache for repo 'updates'

still not solved....!

lightman47
31st August 2017, 09:49 PM
Did you do the 'dnf clean all' prior to your 'dnf distro-sync'?

papai
1st September 2017, 08:30 AM
yes.
1st : 'dnf clean all'
2nd: 'dnf distro-sync'

but getting same error....!

antikythera
1st September 2017, 08:47 AM
in that case open the repository file /etc/yum.repos.d/fedora-updates.repo in a text editor with sudo or admin rights

under [updates]
comment out the metalink with a #symbol at the front of that line.
remove the #symbol from the baseurl entry and alter the address so that it reads as follows for a 64-bit system:

http://download.fedoraproject.org/pub/fedora/linux/updates/26/x86_64

or for 32-bit:

http://download.fedoraproject.org/pub/fedora-secondary/updates/26/i386/
then save the changes and try again

marko
1st September 2017, 09:15 AM
comment out the metalink with a #symbol at the front of that line.
remove the #symbol from the baseurl entry and alter the address so that it reads as follows for a 64-bit system:Just don't do that long term, after it updates correctly a time or two, switch back to the metalink mode

papai
1st September 2017, 07:23 PM
Same error again, after /etc/yum.repos.d/fedora-updates.repo file update.

even, ping google.com gives the following:

PING google.com (172.217.31.14) 56(84) bytes of data.

--- google.com ping statistics ---
8 packets transmitted, 0 received, 100% packet loss, time 7185ms



although, the proxy configured properly in terminal !!!

antikythera
1st September 2017, 09:46 PM
try disabling IPv6 in your network settings.

papai
1st September 2017, 11:05 PM
Oh! god....
Finally its done by exporting the proxy manually !!!!

Thanks a lot for extending your kind supports....