PDA

View Full Version : [SOLVED] File conflict in F26 upgrade



Sight
16th August 2017, 03:39 PM
I'm having a small problem upgrading to F26, I run: sudo dnf system-upgrade download --releasever=26 --allowerasing

Everything appears to run fine until the transaction test then I get this error:

Error: Transaction check error:
file /usr/lib64/sox/libsox_fmt_mp3.so conflicts between attempted installs of sox-plugins-freeworld-14.4.2-1.fc25.x86_64 and sox-14.4.2.0-9.fc26.x86_64

How do I fix this, can I just delete the file?
Currently running F25KDE
Thanks in advance for any help.

PabloTwo
17th August 2017, 01:21 AM
Just deleting the file won't fix the problem. You need to uninstall the package that provides the file. You can try reinstalling the package after the upgrade completes.

Sight
17th August 2017, 12:48 PM
Well that worked, thanks.