PDA

View Full Version : [SOLVED] Live installer (F26) hangs after selecting language



luispa71
13th August 2017, 11:53 PM
Hi,
I'm trying to install Fedora 26 KDE on a laptop (Sony VAIO). The live media boots OK but installer hangs right after trying to continue to the second step (after choosing language). I run the command in a terminal and I get several GTK related error messages, I know it would be useful to know the exact error messages but I don't have the laptop right now.

Did somebody have the same issue?

Any help would be greatly appreciated. Thank you very much in advance,

antikythera
14th August 2017, 08:59 AM
the hang may be when anaconda is actually detecting drives and existing partitions. if you can, leave it and do something else for 5-10 minutes. if it is still sat there doing nothing then it is another issue.

luispa71
14th August 2017, 02:14 PM
Thank you for your reply. I left it for 30-40 minutes and nothing changed.

antikythera
14th August 2017, 02:20 PM
what hardware are you trying to run it on? CPU, GPU etc. the more specifics the better

luispa71
14th August 2017, 03:53 PM
Thank you again for your help. It's a Sony VAIO 14' laptop, CPU is an Intel dual core and it has an integrated Intel graphic card. I guess that hardware is very common and widely supported by Fedora.

luispa71
14th August 2017, 07:21 PM
I was thinking about possible causes, then I remembered that laptop has OpenSuSE Tumbleweed installed with a BTRFS filesystem with lots of partitions created during the installation process. Could that be the cause?

nsnbm
15th August 2017, 12:47 PM
It would be useful to get the error messages which would be on one of the terminals which can be accessed with Ctrl+Alt+F# where # is a number from 1 to 4 or more.

Presumably the f26 is being installed on free space, so anaconda shouldn't have any trouble with other untouched installations.

The media you are using can be checked to see if it's installable. With a dvd disk, you can use the "check this media" program on boot up of the disk. With usb, I think the most reliable method of writing it is using dd. There's lots on the forum about that. I've had many media problems over the years which exhibit similar symptoms to those you describe.

lsatenstein
15th August 2017, 10:17 PM
openSUSE uses btrfs file system. A likely cause of your problem is not btrfs, but lack of space for Fedora.

Using Anaconda's disk space accompanying utility, delete the btrfs partitions and the adjacent swap.
Then continue with the.installation.

luispa71
15th August 2017, 11:38 PM
The culprit was the OpenSUSE BTRFS partition! I formatted it to ext4 with the KDE Partition Manager and the installer did the job flawlessly. Thank you very much for your help.