PDA

View Full Version : After upgrade to Fedora 26 I can not login to normal user. (Login through root is pos



Gippox
13th August 2017, 05:19 PM
Recently I upgraded to Fedora 26 to Fedora 25. Before that everything was working fine. However, after upgrade, I can not login to normal user. Every time I try to login as a normal user it doesn't work. After flash login screen appears again. I tried to login through GNOME, GNOME Classic and GNOME Xorg but it doesn't work on either. However, When I login using "root" user, it works.
But, I can not access all my softwares. So, I need to resolve the problem. Please help!

Thank you!

tryfedoraa
13th August 2017, 06:10 PM
It doesn't explain what happened to your user accounts but worked for others:


It has been suggested to remove your user and your home folder, backing up necessary folders/files (like the Firefox folder ), and then just adding the user again.


https://www.forums.fedoraforum.org/showthread.php?t=41080

nsnbm
14th August 2017, 01:01 AM
You could try changing the user's password with root to see if that makes a difference.

If that fails, you might consider installing another display manager like lightdm. Since root works, you could download it with dnf if your network is good. You then need to make sure that the display manager is enabled with;


systemctl enable graphical.target

Make sure the graphical.target in /etc/systemd/system points to lightdm.

It's possible to have many display managers installed and use the program: system-switch-displaymanager, to switch between them;


The Display Manager Switcher is a tool which enables users to easily switch
between various deskplay managers that they have installed. The tool includes
support for GDM, KDM, XDM, WDM, LightDM, LXDM and SDDM

Gippox
14th August 2017, 06:36 PM
Tanks to all :)
There was a problem in the .cshrc file in my ./home
setenv LD_LIBRARY_PATH /home/andrea/Scrivania/NMMB/NPS/NPS_distrib_v1.4/UTILS/lib/:$LD_LIBRARY_PATH

This user setting blocked startx because he did not find zlib-1.2.9.
I uncommented it and i managed to restart startx and log on through the normal user.

Gippox