PDA

View Full Version : booting into init 5, cannot restore multi-user.default



rumrat
9th August 2017, 01:17 PM
I thpought I would clean out unused programmes, ie. bluetooth associated etc. Any way the net result was gnome become partially removed.

I have recovered all that ok, but the system boots to cli.

I have done the systemctl default multi-user.target....................... but alas i still end up on cli.:dis:

I would be grateful if somebody could punt me in the right direction. Also, direct me to the part of the sys admin manual that explains what the boot sequence is and where the settings are for the graphical desktop. I am rathere exasperated at the mo...............

Thanks in advance.
P

PabloTwo
9th August 2017, 01:31 PM
I have done the systemctl default multi-user.target....................... but alas i still end up on cli.
multi-user.target is cli (init3). For graphical, you need to specify graphical.target.

rumrat
9th August 2017, 02:02 PM
Pablo,
Sorry for the confusion, I was quoting from memory.

Let me set the scene.

When I bootup, the system settles at the cli, I then log in, then type 'startx', which then brings up gnome desktop.

I have done the 'systemctl set-default graphical.target', and when I type 'systemctl get-default' the return is ' graphical.target'. But the system does not jump into graphical desktop, it remains at the cli. What am I missing??

PabloTwo
9th August 2017, 03:04 PM
I have done the 'systemctl set-default graphical.target', and when I type 'systemctl get-default' the return is ' graphical.target'. But the system does not jump into graphical desktop, it remains at the cli. What am I missing??
I really can't say, but obviously some configuration change due to removing so many other packages earlier. I personally don't use Gnome. If memory serves me, I believe there are one or two threads here on the forum that discuss essentially the same issue. Perhaps you could do a search and find them. The search term "/etc/X11/xinit" might lead you there.

Instead of using "startx" after login to cli, see if this command will do the same thing.

# systemctl isolate graphical.target

HaydnH
9th August 2017, 03:39 PM
You didn't remove your graphical login manager (GDM) did you?

srakitnican
9th August 2017, 04:25 PM
https://bugzilla.redhat.com/show_bug.cgi?id=1336959

Closed as EOL no idea if it was fixed, though.

rumrat
9th August 2017, 05:17 PM
Pablo, thanks for the suggestions, but still remain with problem.

HaydnH, no i didn't remove gdm, I checkedthat first, thatnks.

srakitnican, that thread is interesting, thanks I will do some more checks following the thread.

dd_wizard
9th August 2017, 08:46 PM
Is your login manager enabled? I know that lightdm needs to be enabled with systemctl when I build Mate from a minimal install. What do you see when you run "sudo systemctl status gdm"?

dd_wizard

rumrat
9th August 2017, 09:10 PM
dd_wizard,
you're the man........ At last the nugget I needed. Just started gdm and all hunky dory.

I had been everywhere else, but couldn't find the relevant command.

Thanks to all on the forum for your contributions. This is why I love open-source and gnu.