PDA

View Full Version : XWayland mutter keyboard input issue



Ninj0r
7th August 2017, 11:08 PM
I am not sure the best place to put this; I apologize if it is not.

I'm playing a beta game, called Oh Deer! on Fedora 26.
https://necrosoftgames.com/ohdeer/

When I run the game normally from the command line, the keyboard inputs don't work properly.
Some of the keystrokes don't get registered. I've had this issue with other games as well that are being run using XWayland.

I worked through the guide at https://fedoraproject.org/wiki/How_to_debug_Wayland_problems and found that when I run the game from a weston compositor window, the game and inputs work fine.

What's the best way to proceed with reporting this bug so that we can get a mutter fix?

tryfedoraa
8th August 2017, 10:15 PM
It sounds to me like you've already solved the problem? :)

Ninj0r
9th August 2017, 07:08 AM
It sounds to me like you've already solved the problem? :)

Not completely because I should be able to run the game, without issues, using mutter and not have to open a new compositor. I think I've found either a Mutter bug, or Mutter + XWayland bug, and I'd like to report it as it is easily reproducible.