View Full Version : [SOLVED] After f25 to f26 upgrade, perl Gtk3 package fails

7th August 2017, 12:43 AM
I upgraded to f26 on July 23 with no trouble. I have just tried running a perl program that uses the Gtk3 package, and it fails to start, giving the following message

Glib::Object::Introspection object version 0.042 does not match bootstrap parameter 0.040 at /usr/lib64/perl5/DynaLoader.pm line 210.
Compilation failed in require at /usr/share/perl5/vendor_perl/Gtk3.pm line 48.

The perl-Gtk3 and perl-Glib-Object-Introspection packages were both upgraded, so I assume they ought to match. I tried reinstalling them both, just to be sure, but that didn't help.

Any suggestions as to how to proceed?

7th August 2017, 07:13 PM
I managed to solve this. I just removed the /usr/local/lib64/perl5 folder.

As I could understand from google it, was a folder that CPAN installed the perl packages. And when I upgraded the fedora, it conflicted with the system version.


7th August 2017, 11:57 PM
That worked for me too.
Thank you very much.