PDA

View Full Version : dnf autoremove after upgrade from Fedora 24 to 26



User808
6th August 2017, 08:24 PM
Hi.

I just run "sudo dnf autoremove" to see output after upgrading from Fedora 24 to 26 X64 Cinnamon edition. It is:


================================================== ==============================
Package Arch Version Repository Size
================================================== ==============================
Removing:
ORBit2 x86_64 2.14.19-15.fc24 @fedora 591 k
avahi-gobject x86_64 0.6.32-7.fc26 @@commandline 48 k
clang x86_64 4.0.0-3.fc26 @@commandline 6.4 M
clucene09-core x86_64 0.9.21b-16.fc24 @fedora 1.1 M
control-center-filesystem x86_64 1:3.24.3-1.fc26 @@commandline 0
double-conversion x86_64 2.0.1-8.fc26 @@commandline 72 k
f24-backgrounds-gnome noarch 24.1.2-2.fc26 @@commandline 312
fltk x86_64 1.3.4-1.fc26 @@commandline 1.4 M
freerdp-libs x86_64 2:2.0.0-31.20170724gitf8c9f43.fc26
@updates 2.3 M
gcc-c++ x86_64 7.1.1-3.fc26 @@commandline 26 M
gnome-backgrounds-extras noarch 3.24.0-3.fc26 @@commandline 13 M
gnome-python2-bonobo x86_64 2.28.1-19.fc26 @@commandline 374 k
gnome-python2-canvas x86_64 2.28.1-19.fc26 @@commandline 75 k
gnome-python2-gnome x86_64 2.28.1-19.fc26 @@commandline 365 k
gnome-python2-gnomevfs x86_64 2.28.1-19.fc26 @@commandline 340 k
gnome-vfs2 x86_64 2.24.4-22.fc26 @@commandline 1.1 M
gnome-vfs2-common noarch 2.24.4-22.fc26 @@commandline 3.3 M
kdepimlibs-gpgme x86_64 4.14.10-18.fc26 @@commandline 655 k
kio_msits x86_64 7:16.08.3-1.fc24 @updates 35 k
libGLEWmx x86_64 1.13.0-2.fc24 @fedora 471 k
libIDL x86_64 0.8.14-12.fc26 @@commandline 205 k
libart_lgpl x86_64 2.3.21-16.fc26 @@commandline 130 k
libbonobo x86_64 2.32.1-11.fc26 @@commandline 2.0 M
libbonoboui x86_64 2.24.5-11.fc26 @@commandline 1.3 M
libfbclient2 x86_64 3.0.1.32609-5.fc26 @@commandline 1.5 M
libgnome x86_64 2.32.1-12.fc26 @@commandline 4.5 M
libgnomecanvas x86_64 2.30.3-12.fc26 @@commandline 960 k
libgnomeui x86_64 2.24.5-13.fc26 @@commandline 3.6 M
libhbaapi x86_64 2.2.9-9.fc26 @@commandline 49 k
libhbalinux x86_64 1.0.17-4.fc26 @@commandline 73 k
libhif x86_64 0.2.3-1.fc24 @updates 187 k
libkexiv2 x86_64 15.08.3-2.fc24 @fedora 1.6 M
libkscreen x86_64 1:1.0.5-10.fc26 @@commandline 265 k
libwinpr x86_64 2:2.0.0-31.20170724gitf8c9f43.fc26
@updates 966 k
mozjs24 x86_64 24.2.0-11.fc26 @@commandline 5.5 M
newt-python3 x86_64 0.52.20-1.fc26 @@commandline 141 k
perl-Business-ISBN noarch 3.004-1.fc26 @@commandline 52 k
perl-Business-ISBN-Data noarch 20140910.003-4.fc26 @@commandline 181 k
perl-Digest-SHA x86_64 1:5.96-2.fc26 @@commandline 110 k
perl-GD x86_64 2.66-1.fc26 @@commandline 396 k
perl-GD-Barcode noarch 1.15-24.fc26 @@commandline 10 M
perl-IPC-Run3 noarch 0.048-9.fc26 @@commandline 61 k
perl-Mojolicious noarch 7.30-1.fc26 @@commandline 1.8 M
perl-Test-Harness noarch 3.39-1.fc26 @@commandline 565 k
pkcs11-helper x86_64 1.22-1.fc26 @@commandline 141 k
poppler-qt x86_64 0.52.0-4.fc26 @@commandline 519 k
pyorbit x86_64 2.24.0-21.fc26 @@commandline 125 k
python-characteristic noarch 14.3.0-7.fc26 @@commandline 151 k
python3-dnf-plugin-system-upgrade
noarch 2.0.1-1.fc26 @@commandline 55 k
python3-dnf-plugins-extras-common
noarch 2.0.1-1.fc26 @@commandline 103 k
qimageblitz x86_64 0.0.6-12.fc26 @@commandline 114 k
qjson x86_64 0.9.0-2.fc26 @@commandline 194 k
rubygem-json x86_64 2.1.0-100.fc26 @@commandline 123 k
strigi-libs x86_64 0.7.8-12.fc24 @fedora 1.7 M
transmission-cli x86_64 2.92-6.fc26 @@commandline 545 k
uthash-devel noarch 2.0.2-1.fc26 @@commandline 166 k
webkitgtk x86_64 2.4.11-5.fc26 @@commandline 45 M
xorg-x11-drv-libinput x86_64 0.25.1-2.fc26 @@commandline 83 k

Transaction Summary
================================================== ==============================
Remove 58 Packages

Freed space: 143 M
Is this ok [y/N]: N
Operation aborted.


Please notice the following:

1) I run "sudo dnf autoremove" just before system upgrade, so I had no any unused package just before upgrading.

2) I had no any error message during upgrading.

3) after upgrading I check for possible duplicated packages but result was NO ANY DUPLICATED PACKAGES.

4) after upgrading till now I never install/remove any thing unless from command line. I use dnfdragora & GNOME software center just to view packages & their names & searching them no more.

5) I upgraded system from 24 to 26 by tty terminal

6) I upgraded system packages (update system) also by tty terminal.

So, what are your opinion: safe to remove these packages or not ?

Please notice that one of these packages "control-center-filesystem x86_64 1:3.24.3-1.fc26" measured ZERO KB ! How this ?

antikythera
6th August 2017, 08:39 PM
have you run
dnf distro-sync

if not you should do so.

User808
6th August 2017, 09:18 PM
have you run
dnf distro-sync

if not you should do so.

What it's relation to this issue

srakitnican
7th August 2017, 08:47 AM
I admit auto removing stuff installed from command line looks a bit odd as I am not sure what is the behavior with marking as "user install" for a package installed from command line. You can mark some packages as user installed if you don't want this behavior "dnf mark install <package-specs>...". For what you want to keep you be the judge, I would say none of these packages are system critical.

control-center-filesystem as the name suggests, just provides a directory tree that other packages can depend on hence why is so small..

As to why autoremove removes now and not two releases back, maybe dependencies changed and new packages does not depend on these anymore.

User808
7th August 2017, 11:38 PM
Hi.

1) I run:

sudo dnf distro-sync

result was: NO THING TO DO !!

2) regarding: "@@comandline" this term - as I know (please correct to me) - mean package installed as a local .rpm package not from repositories, isn't it ?? But HOW THIS ???? I did not installed any thing as a local .rpm package unless Canon drivers (2 packages only then I remove them) !!

User808
8th August 2017, 03:32 PM
Any coment on my previous replay (#5) ?