PDA

View Full Version : unable to install steam on Fedora 25



dthacker9
30th July 2017, 05:33 PM
Hello!
I'm attempting to install steam on my Fedora 25 system. I'm hitting a lot of dependencies

OS: Fedora 25, KDE Respin
Output of lspci | grep VGA:
03:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RV370 GL [FireMV 2200] (rev 80)


Install so far (as root)
rpm -ivh rpmfusion-free-release-25.noarch.rpm
rpm -ivh rpmfusion-nonfree-release-25.noarch.rpm
dnf install steam

First few lines of error codes from the dnf comman:


file /usr/share/licenses/libpng/LICENSE from install of libpng-2:1.6.27-1.fc25.i686 conflicts with file from package libpng-2:1.6.23-1.fc25.x86_64
file /usr/share/man/man5/png.5.gz from install of libpng-2:1.6.27-1.fc25.i686 conflicts with file from package libpng-2:1.6.23-1.fc25.x86_64
file /usr/share/doc/libidn2/NEWS from install of libidn2-2.0.2-1.fc25.i686 conflicts with file from package libidn2-0.10-4.fc24.x86_64
file /usr/share/doc/libidn2/AUTHORS from install of libidn2-2.0.2-1.fc25.i686 conflicts with file from package libidn2-0.10-4.fc24.x86_64
file /usr/share/info/libidn2.info.gz from install of libidn2-2.0.2-1.fc25.i686 conflicts with file from package libidn2-0.10-4.fc24.x86_64
file /usr/share/man/man1/idn2.1.gz from install of libidn2-2.0.2-1.fc25.i686 conflicts with file from package libidn2-0.10-4.fc24.x86_64
file /usr/share/doc/libxml2/NEWS from install of libxml2-2.9.4-2.fc25.i686 conflicts with file from package libxml2-2.9.3-4.fc25.x86_64
file /usr/share/doc/flac-libs/README from install of flac-libs-1.3.2-1.fc25.i686 conflicts with file from package flac-libs-1.3.1-6.fc24.x86_64
file /usr/share/doc/flac-libs/AUTHORS from install of flac-libs-1.3.2-1.fc25.i686 conflicts with file from package flac-libs-1.3.1-6.fc24.x86_64
file /usr/share/doc/flac-libs/COPYING.Xiph from install of flac-libs-1.3.2-1.fc25.i686 conflicts with file from package flac-libs-1.3.1-6.fc24.x86_64
file /usr/share/locale/de/LC_MESSAGES/elfutils.mo from install of elfutils-libelf-0.169-1.fc25.i686 conflicts with file from package elfutils-libelf-0.167-2.fc25.x86_64
file /usr/share/locale/en@boldquot/LC_MESSAGES/elfutils.mo from install of elfutils-libelf-0.169-1.fc25.i686 conflicts with file from package elfutils-libelf-0.167-2.fc25.x86_64
file /usr/share/locale/en@quot/LC_MESSAGES/elfutils.mo from install of elfutils-libelf-0.169-1.fc25.i686 conflicts with file from package elfutils-libelf-0.167-2.fc25.x86_64
file /usr/share/locale/es/LC_MESSAGES/elfutils.mo from install of elfutils-libelf-0.169-1.fc25.i686 conflicts with file from package elfutils-libelf-0.167-2.fc25.x86_64
file /usr/share/locale/ja/LC_MESSAGES/elfutils.mo from install of elfutils-libelf-0.169-1.fc25.i686 conflicts with file from package elfutils-libelf-0.167-2.fc25.x86_64
file /usr/share/locale/pl/LC_MESSAGES/elfutils.mo from install of elfutils-libelf-0.169-1.fc25.i686 conflicts with file from package elfutils-libelf-0.167-2.fc25.x86_64
file /usr/share/locale/uk/LC_MESSAGES/elfutils.mo from install of elfutils-libelf-0.169-1.fc25.i686 conflicts with file from package elfutils-libelf-0.167-2.fc25.x86_64
file /usr/share/doc/glib2/NEWS from install of glib2-2.50.3-1.fc25.i686 conflicts with file from package glib2-2.50.1-1.fc25.x86_64
file /usr/share/doc/glib2/README from install of glib2-2.50.3-1.fc25.i686 conflicts with file from package glib2-2.50.1-1.fc25.x86_64
file /usr/share/locale/de/LC_MESSAGES/glib20.mo from install of glib2-2.50.3-1.fc25.i686 conflicts with file from package glib2-2.50.1-1.fc25.x86_64
file /usr/share/locale/fr/LC_MESSAGES/glib20.mo from install of glib2-2.50.3-1.fc25.i686 conflicts with file from package glib2-2.50.1-1.fc25.x86_64
file /usr/share/locale/gl/LC_MESSAGES/glib20.mo from install of glib2-2.50.3-1.fc25.i686 conflicts with file from package glib2-2.50.1-1.fc25.x86_64



What should I attempt next?

TIA Dave

srakitnican
30th July 2017, 11:59 PM
Most likely issue with dupes, search the forum on how to resolve it.