PDA

View Full Version : Evolution restore not working... please advice



Anonymous
29th July 2017, 07:28 PM
My evolution mail fails to restore please advice.

evolution-backup-Message: First result 0
evolution.dir
evolution-backup-Message: Second result 0
module-backup-restore-Message: Sanity check result 1:0 0
Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged.
evolution-backup-Message: First result 0
evolution.dir
evolution-backup-Message: Second result 0
evolution-backup-Message: evolution --quit
evolution-backup-Message: mv /home/Marcin/.local/share/evolution /home/Marcin/.local/share/evolution_old
evolution-backup-Message: mv /home/Marcin/.config/evolution /home/Marcin/.config/evolution_old
evolution-backup-Message: cd /tmp && tar -xJf '/home/Marcin/Documents/evolution-backup-20170518.tar.xz' evolution.dir
evolution-backup-Message: cd /home/Marcin/.local/share/evolution && tar --strip-components 3 -xJf '/home/Marcin/Documents/evolution-backup-20170518.tar.xz' '.local/share/evolution'
evolution-backup-Message: cd /home/Marcin/.config/evolution && tar --strip-components 2 -xJf '/home/Marcin/Documents/evolution-backup-20170518.tar.xz' '.config/evolution'
evolution-backup-Message: cat /home/Marcin/.local/share/evolution/backup-restore-dconf-eds.ini | dconf load /org/gnome/evolution-data-server/
evolution-backup-Message: rm /home/Marcin/.local/share/evolution/backup-restore-dconf-eds.ini
evolution-backup-Message: cat /home/Marcin/.local/share/evolution/backup-restore-dconf-evo.ini | dconf load /org/gnome/evolution/
evolution-backup-Message: rm /home/Marcin/.local/share/evolution/backup-restore-dconf-evo.ini
evolution-backup-Message: rm -rf /home/Marcin/.local/share/evolution_old
evolution-backup-Message: rm -rf /home/Marcin/.config/evolution_old
evolution-backup-Message: rm /home/Marcin/.local/share/evolution/.running
rm: cannot remove '/home/Marcin/.local/share/evolution/.running': No such file or directory
evolution-backup-Message: evolution --force-shutdown
Could not find Evolution's process ID
Terminated

tryfedoraa
29th July 2017, 07:36 PM
Can you try restarting the session and see if the problem remains?

Anonymous
29th July 2017, 07:42 PM
I did, same error. Evolution restore seems not to be working for me even with fresh install. Ive tried recreating one mailbox and than creating new backup/restore and it still fails.

Your help would be greatly appreciated.

tryfedoraa
29th July 2017, 08:15 PM
This might help, but assumes you have other a non-evolution backup.


Manually remove .local/share/evolution and .config/evolution directories
Copy both from an old, local backup (not an evolution generated backup, but a plain copy)
Remove .local/share/evolution/mail from that copy
Extract .local/share/evolution/mail manually from an evolution-backup-20150612.tar.gz file (from another system)



https://github.com/voidlinux/void-packages/issues/1823