PDA

View Full Version : [SOLVED] Live USB freeze and partitions



Vampyrebe
26th July 2017, 11:57 AM
Hello all,

I noticed yesterday that Fedora 26 was out. I was on the lookout, and am very interested in this distribution. My needs changed with time, and now I'm pretty confident Fedora is the best way to go with what I aim my computer to be for.

But I meet one big problem. So let's start from the beginning.

Yesterday, I got sick of my Windows machine, and decided it was about time to change its OS. First thing I did, total wipe out of my two disks (SSD and HDD). I then switched over to my Mac, downloaded Fedora 26, burned a USB based on the guide Fedora nicely put out.

This morning, I put the USB in the desktop machine, and start. In the boot, F11 to choose my boot system, switch to UEFI USB and boot it up. I get a choice there and pick Boot live USB. The system starts with a few errors, but then continue with the green OK list. At some point, I get a nice blue screen, with application on the left hand side... and freeze. My mouse doesn't move on the screen, doesn't react to right click. Windows key is unresponsive. Nothing to do, I can't get out of the freeze.

Force reboot, I now pick the non UEFI, follow the same steps. This time around, I move my mouse on the screen. I get the blue screen, see my mouse moving... and then freezes again.

I stopped the machine, and booted my Mac on the USB. No problem there, everything is working like a charm and I conclude there is an issue with my machine, and not my USB.

I boot it up once more, and this time, I take the "Troubleshooting" option, starting Linux in safe mode. There it works. I get my full interface and no freezes.

My first question is then : what if I manage to go through the installer without problem, will the freeze keep coming back when I get out of troubleshooting ? I don't know enough though to troubleshoot it myself. Hence my message here, and my call for help. On the hardware side, I'm with an aging machine now : MSI Motherboard, Nvidia GTX660TI, 8Gb Ram, SSD and HDD. I can exclude the SSD and HDD since I was on USB boot. I fear there is something happening the graphics card, but can't be sure, nor do I know how to fix this issue. Also to be noted, this machine has worked in the past with a Linux Mint Cinnamon, which, if I'm not mistaken is a derivative of Gnome. I truly like the Gnome Desktop, and wouldn't like that it would be incompatible with my machine.

The second question that I have has to do with the partitioning. I know Fedora is working with LVM, for which I'm not at all confident with. I don't even know how it works. So I'm tempted to let Fedora automatically make the partitioning. But... will it use correctly the SSD and HDD ? So in a more direct form : will the automatic partitioning will take care for me of the partition details, while keeping the boot on SSD and the home on HDD ? SSD 128Mb and HDD 1 Tb

Many thanks for your help, suggestion, questions... Thanks !

kldixon
26th July 2017, 02:21 PM
You can start by looking at my post in this thread:
http://forums.fedoraforum.org/showthread.php?t=314914

Given that your machine uses an older Nvidea Kepler (NVE6 (GK106)), your problem with the installer almost certainly arises from the modesetting driver and my workaround will probably solve that problem.

If you are installing Workstation, it uses Wayland which does not seem to be affected.

Since writing that post, I have installed and have not had any problems unless I log in using xorg when I get the same results as described in the bug report. The installed system also uses the modesetting driver and I am about to test the same workaround by creating the /usr/share/X11/xorg.conf.d/10-nouveau.conf file.

As for the partitions, you should read the Installation Guide:
https://docs.fedoraproject.org/en-US/Fedora/26/html/Installation_Guide/index.html
I always use standard partitions which you can get if you use Manual Partitioning.

Post again if you need any more precise advice or recommendations.

kldixon
26th July 2017, 02:44 PM
I am posting this from an xorg session. All seems to be well with the nouveau driver.
However, I did have to reboot. When I logged out of my wayland session and logged back in by an xorg session I got a continuous stream of cache errors from nouveau. I have no idea what that is about.

Vampyrebe
26th July 2017, 02:45 PM
Hey !

Thank you very much for your very fast answer ! It's more than welcomed.

If I understood you right, I should make a new net-install usb key and make a new installation with the net-inst, but I'll encounter a bug by doing so. The work around is to be found in the bugzilla.

1) Boot the netinst iso and, when they become available, switch to a console, with a root prompt, other than tmux or the xserver, e.g. console 2:
Ctrl+Alt+F2

2) Create the following file:
# cat > /usr/share/X11/xorg.conf.d/10-nouveau.conf << "EOF"
Section "OutputClass"
Identifier "Nouveau"
MatchDriver "nouveau"
Driver "nouveau"
EndSection

EOF
and check it:
# cat /usr/share/X11/xorg.conf.d/10-nouveau.conf
This will force the xserver to use the nouveau driver, when it is restarted, if the nouveau kernel module is in use, instead of the modesetting driver.
The nouveau driver is present, even though anaconda will never use it without this xorg.conf.d file:
# ls /usr/lib64/xorg/modules/drivers
ati_drv.so intel_drv.so openchrome_drv.so v4l_drv.so
dummy_drv.so modesetting_drv.so qxl_drv.so vesa_drv.so
fbdev_drv.so nouveau_drv.so radeon_drv.so vmware_drv.so

3) Restart the anaconda service
# systemctl restart anaconda.service

Did I got it right on this one ?

And I'll check your second link for the partitioning.

Very helpful, thank you ! I'll check this as soon as I can and revert back if I find any other problems. Your help is much appreciated !

kldixon
26th July 2017, 03:10 PM
Yep, that's it.
It would be interesting to see how you get along as your GPU is quite a bit newer than mine.
Comment number three from the Phoronix link gives more links to the freedesktop bugzilla which are worth a read.

Vampyrebe
26th July 2017, 04:33 PM
Huuuu... A lot of things seem to be happening wrongly.

I've managed to make the partitions following the design on the page you linked me. Installation went smoothly (it's weird since it uses also the graphical interface).

I made the adaptation to the files as mentioned, but...

I'm still stuck with the mouse not moving and a grey screen (I don't reach the blue one).

:/

Changing consoles is also not working, it's a total freeze...

Vampyrebe
26th July 2017, 08:41 PM
Hey again,

I wanted to bring a small update to my trials.

After my previous try and a complete system failure, I've once again downloaded the normal iso, and went for an installation. First boot from the USB resulted in a failure, with a complete system lock. Not even a console was possible.

Second try, I go the only route that seemed to work so far, starting Fedora from the USB from the troubleshooting link. That gave me access to the live environment, even if I suspect my gfx card is not taken into account. But okay, at least I get to install. So I launch the installer, and make it to the end without problem, and applying the partitioning recommended.

This time, instead of trying tweaking things, I didn't tweaked anything at all and rebooted without a single modification. To my big surprise, it worked ! I am now in the environment. I probably need more research to get my Nvidia card working, but at least I have a working environment now. So that's a step forward. A weird one, but okay, I think I can find how to apply the Nvidia setup and hope this won't crash the whole system once it gets with the Nvidia drivers.

Thank you for your help !

Vampyrebe
26th July 2017, 09:16 PM
\o/

Victory ! I installed the nvidia drivers for my graphic card, and... after reboot, surprise surprise ! Everything works now like a charm. This text is sent from my new Fedora 26 ! I have all the animations now, my nice big resolution. Everything is perfectly working, sound included.

Thank you all !

kldixon
27th July 2017, 02:26 PM
I am pleased you finally succeeded.
I tried to log in last night but the forum was suffering one of its recent problems and would not let me in. Your graphics card is probably recent enough to work with the modesetting driver but requires some other settings and is too new for the nouveau driver.
I was going to suggest that you install the nvidia drivers from a console if you could get some kind of installation, even if with non functioning graphics, but you have done that!