PDA

View Full Version : Lost video after F26 install



bikrgran
22nd July 2017, 08:30 PM
I have an old desktop with Mint 18, and decided to play with Fedora 26, which I understood was HOT! I clean installed it, wiping out the Mint, and all went well. Apparently, though, something went wrong, because my video just went blank. I assumed the video driver would choose the right one, or give me the option of selecting the right one. Maybe it blanked and would have eventually worked. Maybe it went to "sleep" and I don't know how to wake it up. In the end, I put Mint back on. I'd really like to try this, but it's too much trouble, if it's not going to work. I have more than the min. requirements, so don't understand. TIA!

antikythera
22nd July 2017, 10:18 PM
at least supply some system specifications please. without these there's no chance anyone can give you any pointers since it makes a heck of a difference when diagnosing graphics output issues.

bikrgran
23rd July 2017, 03:46 PM
Sorry. Here's what I have: emachine EL1352G-41 4GB DDR3 500GB HD AMD Athlon II X2 220 Dual Core Processor nvidia GeForce 6150 SE nforce 430

Mint is running (open source) xserver-xorg-video nouveau v1:1.0.12-1 build 2 driver, although the recommended one is nvidia-304. I think it was running the recommended before I tried to install Fedora 26, and reinstalled Mint 18.

I put the USB in, last night and booted to Try, but I clicked on activities, then apps, then settings. From there it wouldn't let me click details, or sign on to wifi, or even let me report the problem. I couldn't close the apps window, even doing the force close.

I put the Live DVD in and the screen went flakey. By this time, I just gave up. It was bedtime and I didn't think I was sharp enough to fight it, by that time. I'm thinking of reinstalling it, but wonder if it's worth it. On my other desktop, I found a file in my download folder, LinuxDriver4Fedora_v2.5.0.3.tar.bz2 downloaded in Jan 2017. It hasn't been unzipped, and I don't remember getting it, or why. I must have tried to install Fedora xx then.

OK. I will wait for smarter minds than mine to tackle this. THANKS! :C

kldixon
23rd July 2017, 07:12 PM
I always do a network install, Fedora-Workstation-netinst-x86_64-26-1.5.iso, and I presume you are using Fedora-Workstation-Live-x86_64-26-1.5.iso so I cannot be certain this is the issue you are seeing but F26 seems to have switched to using the modesetting xserver driver, instead of nouveau, by default.
I suffered a black screen from the netinst iso but devised a workaround. The following bug report contains the details and usefull links:

https://bugzilla.redhat.com/show_bug.cgi?id=1470710

However, I have not, as yet, actually done an installation.