View Full Version : Disable error messages for clean graphical boot?

15th July 2017, 12:45 PM
I have a box with F25 with the exact issue noted here by Linus: https://lkml.org/lkml/2016/10/5/299

I have a laptop I just upgraded to F26, which also get it's nice clean graphical boot interrupted by this messages:

kernel: Error parsing PCC subspaces from PCCT

Both installs also show a load of repeating scrolling text that runs by really fast after the graphical shutdown.

Is there any way to hide these messages? as there are no apparent negative effects on my systems as a result. To a normal non developer end user things like this make the operating system look broken.

Surley it would be better to not have these interrupt the boot, while retaining the option to escape the graphical boot. So if something doesn't work you can still check things at boot?

15th July 2017, 01:15 PM

15th July 2017, 02:58 PM
Thanks for the reply, I'm actually already the last comment in the bug report (Matt).

Did I miss a way to do what I'm asking in that report, or did you just link me so I see the report exists?

15th July 2017, 04:40 PM
investigate the options for /proc/sys/kernel/printk I can't find anything current though. I don't want to link you to something 2 years old because it may be outdated.

basically printk arguments set what kernel warning messages are or are not displayed to the user during system start up.

16th July 2017, 10:35 PM
Hi so I did some reading up and appending:

kernel.printk = 3 1 1 3

to /etc/sysctl.conf sets the log levels to less as you suggested, but this doesn't hide the pre Fedora logo boot messages from showing up before the graphical boot gets going.

Does anyone else have any suggestions?

16th July 2017, 10:43 PM
try temporarily adding it to the grub entry for your current boot by pressing e to edit:


title Desktop -- openSUSE 12.1
root (hd0,0)
kernel /vmlinuz-3.3.1 printk.time=3 1 1 3
initrd /initrd-3.3.1