View Full Version : Resolve issues with ATI FC2 driver workaround and video playback

6th June 2004, 11:08 AM
Ok. This is my first time posting a guide, but I thought I might post my solution to the problem up here so other people can get it fixed too!

Basically the problem us ATI users are having with FC2 is that we have no xorg drivers, just XFree, and we have to do some driver patching to get around this and all seems great. Ofcourse, give it some time and you notice that these patches dont create 100% complete drivers. The problem: the patching has some problems with xv video output for media players. So we can either uninstall our 3d acceleration drivers and get media playback, or we can keep 3d acceleration but lose media playback. Sucks.

Anyways, I got everything working and here is how I did it:::

Like most of you, once I installed my ATI drivers and fireg up Mplayer I saw a black screen, but heard music. So, all I did was right click on mplayer, go to preferences, click the "video" tab, select "x11" and press ok. Doing this enables video playback (atleast for me it did). That was great, but after a few minutes I realized it wasn't good enough. If you try to switch to fullscreen you'll encounter some difficulties. The window will go to fullscreen, but the video will stay at the same size, leaving you with a whole bunch of black space. Not what we want.

So, after more poking around I thought about trying VIDIX drivers for ATI. After I got them working I was able to watch videos and resize them. Here's what I did.

1. Uninstall mplayer (if you have it currently installed), including mplayer-fonts.

2. Go to http://luna.cs.ccsu.edu/dominik/apt/fc1/RPMS.testing/ and download the following rpms:

3. Install (g)mplayer:
rpm -Uvh mplayer-common-1.0pre4-4.i386.rpm mplayer-gui-1.0pre4-4.i386.rpm mplayer-skin-default lame-libs-3.96-1.i386.rpm-1.0-2.noarch.rpm

Note: If you recieve an error complaining that lame-libs conflicts with another lame-lib package, then go ahead and uninstall the other one.

4. Now that we've got mplayer installed it's time to get VIDIX installed.
rpm -Uvh mplayer-vidix-1.0pre4-4.i386.rpm mplayer-vidix-ATI-Radeon-1.0pre4-4.i386.rpm

5. Now fire up mplayer (using the command "gmplayer"). Right click, go to preferences, click on the "video" tab, and select VIDIX. Press ok.

Note: I found that it is a good idea to also select "enable double buffering" and "enable direct rendering" because I noticed some slight horizontal line "lag" from time to time. I account for this by the following taken from myplayer documentation:
[the driver] has VSYNC enabled by default. It means that decoding speed (!) is synced to the monitor's refresh rate. So I thought it would be a good idea to make up for this "lagging" but, you dont have to do it it you don't notice any problems. If you do notice problems, try it - it worked for me.

6. Restart mplayer so that the settings take effect.

Everything should play fine now, and fullscreen should work properly.

Note: The reason I said you need to uninstall mplayer, is because the fc2 version that is available on most repositories isn't seen by the VIDIX drivers - I only got them to see the "custom" install of mplayer. If you figure out a way to get them to work with the FC2 version of mplayer, or find FC2 VIDIX drivers, let me know!

I hope this helps you guys... ofcourse I hope we get some REAL drivers soon, not all of these workarounds. :(

6th June 2004, 11:31 AM
Hmm. I just noticed that if I run gmplayer as a user, and not root, then I get errors about not being able to access the display device. However, run it as root and it works fine.


Anyways, atleast it works somewhat. As I said, we need real drivers.... =\

6th June 2004, 12:25 PM
Only root can use the vidix video output, because it does some direct hardware access. Vidix works very well anyway.

Video playback works with the ATI driver. You just have to close some applications like firefox, xmms,... I guess this problem will be fixed in X.org soon.