PDA

View Full Version : Monitor wrong rotated for Asus T100HA



SirEE
3rd May 2016, 09:41 PM
Hello everyone,

I am trying to install a Linux on my Asus Laptop T100HA. All distributions I tried have the screen rotated to the right. This is both for the messages while booting as for the X system.

Although I did not manage to install Ubuntu, I was able to solve the rotation problem for that. For the boot messages I could enter "fbcon=rotate:3", and for the X system the following xorg.conf did help:



Section "Device"
Identifier "Configured Video Device"
Driver "fbdev"
Option "UseFBDev" "true"
Option "Rotate" "CCW"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "800x1280"
EndSubSection
EndSection


Unlike Ubuntu I was able to install Fedora 23. But when putting the above configuration in /etc/X11/xorg.conf.d/01-rotate.conf the system does not start correctly, the last line I see is "Starting Switch Root". I am able to get a console, so I could move that file to another position. So I have a running system, again, but still with the wrong rotation.

In this forum I found suggestions to something like

/usr/bin/xrandr -o right
but from that I get:


X Error of failed request: BadMatch (invalid parameter attributes)
Major opcode of failed request: 139 (RANDR)
Minor opcode of failed request: 2 (RRSetScreenConfig)
Serial number of failed request: 14
Current serial number in output stream 14


If I use -o normal instead of -o right I don't get an error, but it does not change anything, while -o left gives the same error.

Any ideas, suggestions or pointers to a solution?

Thanks in advance

SirEE
8th May 2016, 10:44 AM
Noone with some ideas on this issue? Still looking for a way to get a correct rotation.

nsnbm
8th May 2016, 11:11 AM
In the xorg.conf manpage the options for Rotate are:


Option "Rotate" "rotation"
This optional entry specifies the initial rotation of the given monitor. Valid values for
rotation are "normal", "left", "right", and "inverted".

Perhaps change your configs with that in mind.
I haven't ever had such a problem so I'm just thinking out loud about it here.