View Full Version : FC23 - Solved - how to make lxdm listen on TCP

13th April 2016, 09:55 AM
Hello guys,

I face the following connundrum,

1. I need to get mplayer to work fullscreen on my "slave PC" (small MSI box), while using Synergy to control it from my own desktop. So basically a movie computer.
--> when I use lightdm, the panel bar comes back when I exit the screen with my mouse
--> when I use lxdm, this functionality works perfect.
--> using KDM is like running windoze, having to reboot every 3 days is not my way
--> using Gnome is basically submitting to land occupation, why should I give up 10% of my screen ? besides, gnome-shell slows evertything down.

2. So I settled on lxdm, but since this computer must stay on all the time due to its low power consumption, I need it to listen on TCP, so I can pipe in some xterms from some remote servers I have running around.

3. If I edit /etc/lxdm/lxdm.conf I can see the following setting:
# uncomment this if you really want xserver listen to tcp

If I uncomment this, the X server will STILL not listen to tcp.
So, I was looking at that file, and I found right above the section:
## arg used to start xserver, not fully function

BINGO, so I added something to it, now my line looks like this:
arg=/usr/bin/X -background none vt1 -listen tcp

And guess what !!! IT WORKS.

So now I have my synergy controlled small hidden PC for watching movies and hosting small xterms from remote servers. What a day !