View Full Version : 64 bit NDisWrapper?

2nd January 2005, 09:03 PM
I have FC3 64 bit version on my HP Pavilion, and I am trying to find some information about NdisWrapper . I read that NDiswrapper is not supported for 64 bit . I want to figure out how I can get my Broadcom wireless working. I have also learned of support through Linuxant DriverLoader, and that DriverLoader even supports 64 bit, but you also have to have a 64 bit driver. If anyone knows of a way to run Ndiswrapper on FC3_64 , OR knows of a 64 bit driver for the Broadcom 802.11g it would be appreciated. Or if anyone knows any additional information of the subject. Thanks, Chad

8th January 2005, 06:50 AM
I was able to get my Broadcom wireless card thanks to the Linuxant DriverLoader and with a 64 bit driver obtained from a Windows XP_64 .

8th June 2005, 02:32 PM
THe 64-bit Broadcom drivers can be found here (http://www.linuxant.com/driverloader/drivers.php).

It's the one at the very top of the list.
Ndiswrapper DOES work under x86_64, (it's worked for me under SuSE and Gentoo, so I'm assuming it'll also work under Fedora -- which I'll find out in about 3 hours). To install the driver you just have to cd into the directory where the unzipped drivers are, and enter ndiswrapper -i <inf file> and it'll install the driver,

ndiswrapper -l gives you a list of installed drivers and tells you if the hardware is present

Afterthat you just have to modprobe ndiswrapper and (if you become your IP through dhcp) dhcpcd wlan0 and that should do the trick.

NOTE: If you want to connect to a VPN, I'Ve heard that ndiswrapper and the cisco vpnclient don't get along to well, other than that I haven't experienced any Problems.

Hope this helps

16th March 2006, 02:23 AM
Hi - I've tried to modprobe ndiswrapper and I get this:

Patti@PattiHome3:~> su
PattiHome3:/home/Patti # ndiswrapper -l
Installed ndis drivers:
netbc564 driver present
PattiHome3:/home/Patti # modprobe ndiswrapper
FATAL: Module ndiswrapper not found.
PattiHome3:/home/Patti #

THis seems VERY strange to me!! Ideas on how to fix? I've removed and reinstalled...