PDA

View Full Version : Fix Kdenlive "Cannot talk to klauncher"



piga
12th March 2016, 02:52 AM
When I updated my Fedora 23 system about a month ago Kdenlive became unusable. Whenever I tried adding anything to a project I would get this message:

Could not start process
Cannot talk to klauncher: The name org.kde.klauncher5 was not provided by any .service files.

After finding this post (http://askubuntu.com/questions/617955/problem-with-kde-programs-after-upgrading-to-15-04/617956), I found that the solution was also applicable to Fedora 23.

I used the command:

sudo dnf install kf5-kio.i686 kf5-kio.x86_64 krb5-pkinit.x86_64 kf5-kinit-devel.i686 kf5-kinit-devel.x86_64 kf5-kinit.i686 kf5-kinit.x86_64 kstart.x86_64

I do not know if all of the packages I installed were necessary (particularly the 32-bit and development ones). However, since the issue was a lack of installed packages, I just installed everything that came up in a dnf search for "kinit" (as well as kf5-kio.i686 and kf5-kio.x86_64).

From this, Kdenlive is now working again, and my fix may help others.

I wonder why these packages were not considered dependencies as part of updating Kdenlive?

gingerling
11th May 2016, 01:27 AM
thanks buddy, you rocked that for me! First time editing on new super-hot laptop was looking to be disappointing, you saved me! :dance:

Guangyuan
15th May 2016, 09:15 AM
Thanks a lot ! You really help me !:thumb:

Jusko
28th May 2016, 12:00 AM
In case of x64 system, this package was sufficient (in my case):


kf5-kinit.x86_64

Problem solved :)

patjolla
19th June 2016, 11:26 AM
Thank you really worked for me! :) :thumb:

gzone
22nd June 2016, 06:58 PM
When I updated my Fedora 23 system about a month ago Kdenlive became unusable. Whenever I tried adding anything to a project I would get this message:


After finding this post (http://askubuntu.com/questions/617955/problem-with-kde-programs-after-upgrading-to-15-04/617956), I found that the solution was also applicable to Fedora 23.

I used the command:

sudo dnf install kf5-kio.i686 kf5-kio.x86_64 krb5-pkinit.x86_64 kf5-kinit-devel.i686 kf5-kinit-devel.x86_64 kf5-kinit.i686 kf5-kinit.x86_64 kstart.x86_64

I do not know if all of the packages I installed were necessary (particularly the 32-bit and development ones). However, since the issue was a lack of installed packages, I just installed everything that came up in a dnf search for "kinit" (as well as kf5-kio.i686 and kf5-kio.x86_64).

From this, Kdenlive is now working again, and my fix may help others.

I wonder why these packages were not considered dependencies as part of updating Kdenlive?

Thanks, better to have it and not need it, then need it and not have it!