PDA

View Full Version : libssl.so.1.0.0 on Fedora 23



libor
26th February 2016, 02:54 PM
I solved installation problem of Eagle layout editor for linux on Fedora 23. The installation requested libssl.so.1.0.0 and libcrypto.so.1.0.0 which Fedora 23 does not contain. See the reply of the installation:

[libor@medvidek eagle750]$ ./eagle-lin-7.5.0.run
Ensure the following 32 bit libraries are available:
libssl.so.1.0.0 => not found
libcrypto.so.1.0.0 => not found

/tmp/eagle-setup.13655/eagle-7.2.0/bin/eagle: error while loading shared
libraries: libssl.so.1.0.0: cannot open shared object file: No such file
or directory
[libor@medvidek eagle750]$

The solution is to make symlinks as bellow:

# ln -s /usr/lib/libssl.so.10 /usr/lib/libssl.so.1.0.0
# ln -s /usr/lib/libcrypto.so.10 /usr/lib/libcrypto.so.1.0.0

After that the installation runs without error :)