PDA

View Full Version : F23 perl dependecy problem



makgab
19th December 2015, 09:48 PM
Hi!
I got this:


sudo dnf update
Last metadata expiration check performed 0:13:00 ago on Sat Dec 19 21:31:03 2015.
Függőségek feloldva.
================================================== =====================================
Package Arch Verzió Tároló Méret
================================================== =====================================
Skipping packages with broken dependencies:
perl x86_64 4:5.22.1-350.fc23 updates 6.9 M
perl-IO-Zlib noarch 1:1.10-350.fc23 updates 65 k
perl-Locale-Maketext-Simple noarch 1:0.21-350.fc23 updates 64 k
perl-Math-BigInt noarch 1.9997-350.fc23 updates 188 k
perl-Math-Complex noarch 1.59-350.fc23 updates 93 k
perl-devel x86_64 4:5.22.1-350.fc23 updates 550 k
perl-libs x86_64 4:5.22.1-350.fc23 updates 822 k
perl-macros x86_64 4:5.22.1-350.fc23 updates 57 k
perl-open noarch 1.10-350.fc23 updates 62 k

Tranzakció Összegzés
================================================== =====================================
Skip 9 Packages

Nincs tennivaló.
Kész!


(source: update)

Any idea for this problem?

jbkt23
19th December 2015, 11:50 PM
The answer is usually in the output that precedes this text. It is usually another package that is not quite in updates yet.

PabloTwo
20th December 2015, 02:34 AM
Unfortunately, dnf is not as informative about some things as yum is. You might try adding the -v (verbose) option to the command to see if dnf will reveal more about the dependency issue here.

makgab
20th December 2015, 08:49 AM
Unfortunately, dnf is not as informative about some things as yum is. You might try adding the -v (verbose) option to the command to see if dnf will reveal more about the dependency issue here.



sudo dnf upgrade -v
cachedir: /var/cache/dnf
Loaded plugins: reposync, protected_packages, debuginfo-install, langpacks, generate_completion_cache, system-upgrade, builddep, config-manager, copr, playground, noroot, needs-restarting, download, Query
langpacks: No languages are enabled
Adding hu_HU to language list
Adding en to language list
initialized Langpacks plugin
DNF version: 1.1.4
repo: using cache for: postinstallerf
not found deltainfo for: PostInstallerF
not found updateinfo for: PostInstallerF
repo: using cache for: rpmfusion-free-updates-testing
not found deltainfo for: RPM Fusion for Fedora 23 - Free - Test Updates
not found updateinfo for: RPM Fusion for Fedora 23 - Free - Test Updates
repo: using cache for: google-webdesigner
not found deltainfo for: google-webdesigner
not found updateinfo for: google-webdesigner
repo: using cache for: rpmfusion-nonfree
not found deltainfo for: RPM Fusion for Fedora 23 - Nonfree
not found updateinfo for: RPM Fusion for Fedora 23 - Nonfree
repo: using cache for: rpmfusion-nonfree-updates-testing
not found deltainfo for: RPM Fusion for Fedora 23 - Nonfree - Test Updates
not found updateinfo for: RPM Fusion for Fedora 23 - Nonfree - Test Updates
repo: using cache for: google-chrome
not found deltainfo for: google-chrome
not found updateinfo for: google-chrome
repo: using cache for: fedora
not found deltainfo for: Fedora 23 - x86_64
not found updateinfo for: Fedora 23 - x86_64
repo: using cache for: rpmfusion-free
not found deltainfo for: RPM Fusion for Fedora 23 - Free
not found updateinfo for: RPM Fusion for Fedora 23 - Free
repo: using cache for: adobe-linux-x86_64
not found deltainfo for: Adobe Systems Incorporated
not found updateinfo for: Adobe Systems Incorporated
repo: using cache for: updates
repo: using cache for: postinstallerf-updates
not found deltainfo for: PostInstallerF-updates
not found updateinfo for: PostInstallerF-updates
postinstallerf: using metadata from Thu Oct 22 08:27:25 2015.
rpmfusion-free-updates-testing: using metadata from Wed Dec 16 08:48:39 2015.
google-webdesigner: using metadata from Fri Nov 13 20:32:46 2015.
rpmfusion-nonfree: using metadata from Sun Oct 11 17:50:38 2015.
rpmfusion-nonfree-updates-testing: using metadata from Wed Dec 16 08:53:53 2015.
google-chrome: using metadata from Thu Dec 17 00:24:57 2015.
fedora: using metadata from Sat Oct 31 18:34:41 2015.
rpmfusion-free: using metadata from Sun Oct 11 18:43:19 2015.
adobe-linux-x86_64: using metadata from Mon Nov 30 20:25:58 2015.
updates: using metadata from Sat Dec 19 19:04:50 2015.
postinstallerf-updates: using metadata from Sat Nov 7 03:23:22 2015.
Last metadata expiration check performed 0:30:32 ago on Sun Dec 20 08:17:02 2015.
--> Függőségek feloldásának kezdete
--> A függőségek feloldása befejeződött
Függőségek feloldva.
langpacks: enabled languages are ['hu', 'hu_HU', 'en']
================================================== ================================================== ================================================== ================================================== ================================================== ====================
Package Arch Verzió Tároló Méret
================================================== ================================================== ================================================== ================================================== ================================================== ====================
Skipping packages with broken dependencies:
perl x86_64 4:5.22.1-350.fc23 updates 6.9 M
perl-IO-Zlib noarch 1:1.10-350.fc23 updates 65 k
perl-Locale-Maketext-Simple noarch 1:0.21-350.fc23 updates 64 k
perl-Math-BigInt noarch 1.9997-350.fc23 updates 188 k
perl-Math-Complex noarch 1.59-350.fc23 updates 93 k
perl-devel x86_64 4:5.22.1-350.fc23 updates 550 k
perl-libs x86_64 4:5.22.1-350.fc23 updates 822 k
perl-macros x86_64 4:5.22.1-350.fc23 updates 57 k
perl-open noarch 1.10-350.fc23 updates 62 k

Tranzakció Összegzés
================================================== ================================================== ================================================== ================================================== ================================================== ====================
Skip 9 Packages

Nincs tennivaló.
Completion plugin: Generating completion cache...
Kész!



It seems bug?

jbkt23
20th December 2015, 04:18 PM
Searching this term:
dnf broken dependencies
gave me a thread that said use:

dnf upgrade --best

to get a list of dependencies. See if that helps.

makgab
20th December 2015, 09:17 PM
I tried it:


# sudo dnf upgrade --best --allowerasing
Last metadata expiration check performed 0:01:58 ago on Sun Dec 20 21:09:06 2015.
Error: package polymake-2.14r1-2.fc23.x86_64 requires perl = 4:5.22.0, but none of the providers can be installed.
package perl-4:5.22.0-349.fc23.x86_64 requires perl-libs = 4:5.22.0-349.fc23, but none of the providers can be installed


So, I remove the "polymake" package: dnf remove polymake

Then I can run the dnf update. :)
Thanx!

jbkt23
21st December 2015, 01:44 AM
If you can mark this solved that will help others who don't know the new dnf syntax. I can't remember how to do that so hopefully another on this forum can explain.