PDA

View Full Version : USB Drive Not Showing in Nautilus



linuxthunder
29th November 2015, 11:56 PM
Greetings,

I am using Fedora 23 Gnome 3.18 and I plug in an 8GB Sandisk Cruzer Edge USB drive but it doesn't show up in nautilus.

dmesg says that it is /dev/sdc

fdisk -l /dev/sdc shows:


Disk /dev/sdc: 7.5 GiB, 8004304896 bytes, 15633408 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


My linux skills are very limited but these are the commands I was able to find to identify the device.

Please let me know if you need more information and thank you for your patience with my question.

JONOR
1st December 2015, 11:18 PM
My Cruzer would not work at first but later did, maybe there was a delay while the system downloaded and installed some usb software drivers for the thumbdrive.
Here is roughly what was done :
1. Plugged in Cruzer, nothing in Nautilus Files file browser. This was the first thumbdrive to be tried in F23 after upgrade.
2. Tried to find Cruzer using both Disks and Gparted, nope.
3. Removed Cruzer and tried another brand of thumbdrive, did show in Files, Disks and Gparted.
4. Removed other brand and tried Cruzer again, still nothing in Files.
5. Tried to find Cruzer using Gparted again and now it did show, along with Disks and finally Files too, there was a space of about 2 minutes between first and second attempts.

linuxthunder
2nd December 2015, 12:42 AM
Thanks for the information. Mine is still not showing up in Nautilus but it is there in disks and in the command line. I tried it on a debian-based machine and it is the same problem as well and the command line says that there are no partitions.

I think I need to partition the drive somehow but I'm not sure how to do it. Thanks in advance if you know how to do this.

linuxthunder
2nd December 2015, 12:55 AM
Ok, this was an easy fix. I just created a fat32 partition with Disks for the entire drive and now it works perfectly!

thanks