PDA

View Full Version : Exclude package from Fedora repo?



teraquad
24th November 2015, 10:13 PM
Hi,

I am trying to install zoneminder from it's own repo. in the past i would edit yum.conf and be on my way. That has changed in fedora 23 and i need direction.

I have done some searching on the web and cannot find anything on this subject. It seems DNF is involved now and i can find no clear instruction.

Thanks for any help on this I am trying to exclude zoneminder install from the fedora repository so it will use the zoneminder repository.

joncr
24th November 2015, 10:33 PM
You add an "exclude=" line to /etc/dnf/dnf.conf.

See 'man dnf.conf'.

teraquad
24th November 2015, 11:00 PM
Thank you very much I have been wondering and considering that action but I wanted to make sure.

Thanks!


Sent from my SM-T810 using Tapatalk

marko
25th November 2015, 12:59 AM
You can also put the same exclude line in the particular repo file in /etc/yum.repos.d/
The advantage there is it would work for both dnf and yum-deprecated

PabloTwo
25th November 2015, 01:20 AM
"man dnf.conf" has all the answers to your dnf configuration questions.

teraquad
25th November 2015, 09:25 AM
Hi,

I added the "exclude=zoneminder*" line to my fedora repo file. it now complains.


[root@tera-two yum.repos.d]# dnf install zoneminder
Config error: Error parsing "clean_requirements_on_remove = 'tru'": invalid boolean value
[root@tera-two yum.repos.d]#
Perhaps someone can show me the error of my ways.


[root@tera-two yum.repos.d]# cat fedora.repo
[fedora]
name=Fedora $releasever - $basearch
failovermethod=priority
#baseurl=http://download.fedoraproject.org/pub/fedora/linux/releases/$releasever/Everything/$basearch/os/
metalink=https://mirrors.fedoraproject.org/metalink?repo=fedora-$releasever&arch=$basearch
enabled=1
metadata_expire=28d
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$releasever-$basearch
skip_if_unavailable=False

exclude=zoneminder*

[fedora-debuginfo]
name=Fedora $releasever - $basearch - Debug
failovermethod=priority
#baseurl=http://download.fedoraproject.org/pub/fedora/linux/releases/$releasever/Everything/$basearch/debug/
metalink=https://mirrors.fedoraproject.org/metalink?repo=fedora-debug-$releasever&arch=$basearch
enabled=0
metadata_expire=28d
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$releasever-$basearch
skip_if_unavailable=False

[fedora-source]
name=Fedora $releasever - Source
failovermethod=priority
#baseurl=http://download.fedoraproject.org/pub/fedora/linux/releases/$releasever/Everything/source/SRPMS/
metalink=https://mirrors.fedoraproject.org/metalink?repo=fedora-source-$releasever&arch=$basearch
enabled=0
metadata_expire=28d
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$releasever-$basearch
skip_if_unavailable=False

[root@tera-two yum.repos.d]#
Thanks for any help you can provide.

Thanks! George....

marko
25th November 2015, 10:10 AM
edit your /etc/dnf/dnf.conf file and fix the typo on that line


It should look like


clean_requirements_on_remove=True