PDA

View Full Version : [SOLVED] "LSB Up/Down start" takes too long



mpajoh
17th November 2015, 04:38 PM
When I boot up the "LSB Up/Down start" takes too long, I think.
Then checking with:

systemd-analyze blame

shows the top offenders:


1min 32.790s network.service
31.737s NetworkManager-wait-online.service
.
.
Is there a way to make this faster?

Thanks for all the help.

nsnbm
18th November 2015, 12:36 AM
It looks like both network and NetworkManager are running. Normally, only one of those runs to manage the network. Perhaps choose one and disable the other. They can interfere with each other in the way they each deal with configuration files.

mpajoh
18th November 2015, 02:53 PM
It looks like both network and NetworkManager are running. Normally, only one of those runs to manage the network. Perhaps choose one and disable the other. They can interfere with each other in the way they each deal with configuration files.

nsnbm thanks for the advice.

Any advice on which one to keep?
How can I to disable the other?


Thanks again for looking.

nsnbm
18th November 2015, 11:57 PM
if you choose NetworkManager, enable it, and restart it with (as root) after stopping and disabling network:


systemctl stop network
systemctl disable network
systemctl enable NetworkManager
systemctl restart NetworkManager

network can alternatively, be stopped with chkconfig:


chkconfig --levels 2345 network off

and then check to see if it is off:


[tom@owl ~]$ chkconfig

Note: This output shows SysV services only and does not include native
systemd services. SysV configuration data might be overridden by native
systemd configuration.

If you want to list systemd services use 'systemctl list-unit-files'.
To see services enabled on particular target use
'systemctl list-dependencies [target]'.

livesys 0:off 1:off 2:off 3:on 4:on 5:on 6:off
livesys-late 0:off 1:off 2:off 3:on 4:on 5:on 6:off
netconsole 0:off 1:off 2:off 3:off 4:off 5:off 6:off
network 0:off 1:off 2:off 3:off 4:off 5:off 6:off

xinetd based services:

After starting and enabling and stopping, a reboot should ensure that all the instructions are in place and then NetworkManager should be running the network. Personally, I run network and configure the devices myself and so I'm not that familiar with NetworkManager, but it's supposed to be fairly self-supporting in running the network and has the GUI.

mpajoh
23rd November 2015, 02:30 PM
Thanks nsnbm, that worked perfectly well.

And now the:

systemd-analyze blame
returns:

.
.
.
1.049s NetworkManager.service
.
.
.
way down the list.

Thanks again.