PDA

View Full Version : Reinstalling grub2



glennzo
17th November 2015, 10:59 AM
On an EFI system. I'd like to install / reinstall grub to the MBR. How has the command changed from

grub2-install /dev/sda


I'm currently booting Fedora 23, Mint 17 and Windows 10. Mint's GRUB is doing the dirty work. I'd like to make Fedora's GRUB the one in control.

I'm not getting it. Could someone shine some light please?

smr54
17th November 2015, 12:08 PM
Are you getting an error or is it just not working? That is, you run the command, reboot, and see that Mint's grub is still in control?

glennzo
17th November 2015, 12:15 PM
Hi Scott. I'll take the "just not working" option. Although I'd like to know how this is done from the command line, as I've always done it in the past, I've gone ahead and installed grub customizer and used it to solve my issue for the time being.

nonamedotc
17th November 2015, 02:54 PM
As for as I know grub2-install should not be used in EFI systems.

See this page for instructions - https://fedoraproject.org/wiki/GRUB_2#Updating_GRUB_2_configuration_on_UEFI_syste ms

glennzo
17th November 2015, 02:59 PM
Was reading that (and many other pages) before I posted here. Didn't work.

smr54
17th November 2015, 03:14 PM
I only have Windows on VMs, so can't really help, Glenn, I'm sorry. Heh, there's the solution, remove Windows, change it to old style booting, and you're done. :)

I realize that's probably not practical. But, with Mint, did you run any special commands or was it installed last and just did it automatically?

antikythera
17th November 2015, 03:53 PM
try this


grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg

plasmonics
18th November 2015, 02:44 PM
This happened to me once before when my partition table got renumbered and i couldnt boot the OS. So I deleted grub2, grub2-efi, and grub2-efi-modules and then reinstalled them.
It worked. If I recall, it has to be done in a chrooted environment and the ESP has to be mounted at /boot/efi. The web page mentions using yum reinstall. This didnt work for me. Had to delete everything first.

grub2-install also worked, but the bootloader looks for grub.cfg in /boot/grub2 not /boot/efi/EFI/fedora. The first method restores it to factory.