PDA

View Full Version : After using grub customizer. f22 stuck on booting.



whitefish
9th November 2015, 11:32 AM
Hi guys, I am one of the people who is using f22 with kernel 4.1 because of the issues of kernel 4.2 with Nvidia drivers. Also, with the system update I have kernel 4.2 install up the grub boot list, but I am not using.

So, I used grub customizer for switch the order to:-

kernel 4.1
rescue
kernel 4.2
kernel 4.0.4

Before the grub customizer I used to select kernel 4.1 from the list to boot fedora. But after customizing and putting kernel 4.1 on top. It stuck at fedora boot logo.

I tried to fix this by resinstall the "grub2-install /dev/sdd" but the result is the same.

Please advice me on what to do here. And thank you.

nsnbm
10th November 2015, 12:11 AM
To change the to the kernel I prefer on the menu, I use the default option in /etc/default/grub and then run grub2-mkconfig pointing to the correct file. This is from the grub manual:


13.1.6 default

If this variable is set, it identifies a menu entry that should be selected by default, possibly after a timeout (see timeout). The entry may be identified by number or by title.

If the entry is in a submenu, then it must be identified using the titles of each of the submenus starting from the top level followed by the number or title of the menu entry itself, separated by ‘>’. For example, take the following menu structure:

Submenu 1
Menu Entry 1
Menu Entry 2
Submenu 2
Submenu 3
Menu Entry 3
Menu Entry 4
Menu Entry 5

“Menu Entry 3” would then be identified as ‘Submenu 2>Submenu 3>Menu Entry 3’.

This variable is often set by ‘GRUB_DEFAULT’ (see Simple configuration), grub-set-default, or grub-reboot.