PDA

View Full Version : gnome-calculator has changed help.



Ernst0
26th October 2015, 12:16 PM
I had worked on RHEL6 for a long time and gnome-calculator (gcalctool) is something I depend on.
This new gnome-calculator in Fedora 22 doesn't seem to allow me to have the binary display on. When I type a number in instead of the value being displayed in the binary display area that area is shadowed and no data is displayed. Also the results are displayed in scientific notation when I need integer form.

Naturally I am in Programming mode so having the values displayed in scientific notation also is problematic.


I tried to pull up man gnome-calculator to see how to configure gnome-calculator but that was of no help.

Where do I or what do I do to get rid of the scientific display because I do need the integers not the scientific notation form and how do I turn on the binary display?

Thanks Fedora 22 is cool but it's a bit awkward if one is used to RHEL6 with gnome-calculator there seems to be no pull down menus, no configuration.

Thanks

WWDERW
26th October 2015, 12:25 PM
I get a binary option underneath the display window on the left size, there is a drop down with Binary as an option. Is that the Binary option you are wanting?

PatMcLJr
26th October 2015, 01:51 PM
on mine the little calculator in the top left corner has a menu and one of the items is preferences, you can select the number format there

alphacrucis
27th October 2015, 12:39 AM
Looks like it changed again in f23. (ie gnome 3.18.1) it has a mode dropdown. To get binary it appears you have to select "programming mode" from the main dropdown. Then you can select decimal, binary, octal or hexadecimal.

WWDERW
27th October 2015, 01:04 AM
Looks like it changed again in f23. (ie gnome 3.18.1) it has a mode dropdown. To get binary it appears you have to select "programming mode" from the main dropdown. Then you can select decimal, binary, octal or hexadecimal.


That's the way that it is in F22. I wish I could post a screen shot, but it keeps on failing when I try to upload it to the site.

lsatenstein
27th October 2015, 01:28 AM
I was able to set binary, hex, scientific,etc.

DBelton
27th October 2015, 02:50 AM
I just use qalculate instead. Much better calculator than the one in Gnome.



dnf install qalculate-gtk

Ernst0
27th October 2015, 03:42 AM
Doh!

Wasn't looking in the very top of the screen where it is separate from the body of the calculator now

Okay then I get it. All the functionality I am used to is there and there are some new features.

I have to say I was annoyed in having to switch between mode to access some functions before.
Now those functions are on the programming.

Thanks