PDA

View Full Version : systemd failed to load kernel modules?



LinuxPinux
22nd October 2015, 11:21 AM
Hello guys. Hopefully get some help on my first post..

I have noticed when booting I get "systemd[1]: Failed to start Load Kernel Modules.". Should I be worried about this? I am running 4.2.3-200.fc22.x86_64. Not sure what other info you may need but if you do need anything just ask please.

vallimar
22nd October 2015, 11:37 AM
Could be nothing, could be important.
What does the output of "systemctl status systemd-modules-load.service" indicate?

You can also try running "sudo /usr/lib/systemd/systemd-modules-load" manually
to see if that produces any errors.

LinuxPinux
22nd October 2015, 08:34 PM
systemctl status systemd-modules-load.service

● systemd-modules-load.service - Load Kernel Modules
Loaded: loaded (/usr/lib/systemd/system/systemd-modules-load.service; static; vendor preset: disabled)
Active: failed (Result: exit-code) since Thu 2015-10-22 15:23:27 EDT; 8min ago
Docs: man:systemd-modules-load.service(8)
man:modules-load.d(5)
Process: 593 ExecStart=/usr/lib/systemd/systemd-modules-load (code=exited, status=1/FAILURE)
Main PID: 593 (code=exited, status=1/FAILURE)

Oct 22 15:23:27 h4x0r systemd-modules-load[593]: Failed to find module 'vboxdrv'
Oct 22 15:23:27 h4x0r systemd-modules-load[593]: Failed to find module 'vboxnetflt'
Oct 22 15:23:27 h4x0r systemd-modules-load[593]: Failed to find module 'vboxnetadp'
Oct 22 15:23:27 h4x0r systemd-modules-load[593]: Failed to find module '///////////////////////////////////////////////'
Oct 22 15:23:27 h4x0r systemd[1]: systemd-modules-load.service: main process exited, code=exited, status=1/FAILURE
Oct 22 15:23:27 h4x0r systemd[1]: Failed to start Load Kernel Modules.
Oct 22 15:23:27 h4x0r systemd[1]: Unit systemd-modules-load.service entered failed state.
Oct 22 15:23:27 h4x0r systemd[1]: systemd-modules-load.service failed.


sudo /usr/lib/systemd/systemd-modules-load

Failed to find module 'vboxdrv'
Failed to find module 'vboxnetflt'
Failed to find module 'vboxnetadp'
Failed to find module '///////////////////////////////////////////////'
Failed to find module '///////////////////////////////////////////////'


Hm.. Looks like something with virtual box? (I have Oracle VirtualBox installed). No clue what all those ///'s could be.

LinuxPinux
23rd October 2015, 08:19 PM
Am I able / allowed to bump this? Still having this problem and would love help.

SomeDamFool
23rd October 2015, 10:19 PM
Maybe the modules need updating. Have you installed kmod-Virtualbox or akmod-Virtualbox?

vallimar
24th October 2015, 04:58 AM
If you are using the Oracle package, you may need to manually rebuild the modules for a newer kernel?
Maybe try removing VirtualBox and installing the latest version from the website.

LinuxPinux
25th October 2015, 01:59 PM
Maybe the modules need updating. Have you installed kmod-Virtualbox or akmod-Virtualbox?

Yes.


If you are using the Oracle package, you may need to manually rebuild the modules for a newer kernel?
Maybe try removing VirtualBox and installing the latest version from the website.

I think this may be the problem as I checked and kmod-VirtualBox is outdated for my current kernel.

bobatlcpmbdx
28th February 2017, 12:45 PM
I have the same error at startup

I do not have virtual box installed

I do have a persistant problem with Broadcom wifi which seems to fail on kernel update but not every time. (but thats not what I am writing about)

last update caused the problem :- 4.9.11-200.fc25.x86_64


The result of "systemctl status systemd-modules-load.service"


systemd-modules-load.service - Load Kernel Modules
Loaded: loaded (/usr/lib/systemd/system/systemd-modules-load.service; static; vendor preset: disabled)
Active: failed (Result: exit-code) since Tue 2017-02-28 11:23:41 GMT; 44s ago
Docs: man:systemd-modules-load.service(8)
man:modules-load.d(5)
Process: 2682 ExecStart=/usr/lib/systemd/systemd-modules-load (code=exited, status=1/FAILURE)
Main PID: 2682 (code=exited, status=1/FAILURE)

Feb 28 11:23:41 fred10 systemd[1]: Starting Load Kernel Modules...
Feb 28 11:23:41 fred10 systemd[1]: systemd-modules-load.service: Main process exited, code=exited, status=1/FAILURE
Feb 28 11:23:41 fred10 systemd[1]: Failed to start Load Kernel Modules.
Feb 28 11:23:41 fred10 systemd[1]: systemd-modules-load.service: Unit entered failed state.
Feb 28 11:23:41 fred10 systemd[1]: systemd-modules-load.service: Failed with result 'exit-code'.

any ideas would be welcomed