PDA

View Full Version : Fedora 22 can not auto mount share folder (pam_mount)



impuls
21st August 2015, 11:35 AM
I have the server windows 2008 r2 (dс, ip-10.2.13.1). On it there is the share folder \\DC\Documents.
I have some computers with system RFRemix 15 and RFRemix 20.1 in my network.
When I log on to the computer with a network user a_malkov (for example) is mounting the network folder \\DC\Documents.

I installed new Fedora 22. At now, when I log on to the Fedora 22 - nothing happens. Share folder \\DC\Documents is not automount.
But I can mount share folder in console Fedora 22:
$ su a_malkov

What's the problem ? Who can help me? Where to look for a problem?
Please!!!

Configs Fedora 22:
/etc/pam.d/system-auth-ac

#%PAM-1.0
# This file is auto-generated.
# User changes will be destroyed the next time authconfig is run.
auth required pam_mount.so
auth required pam_env.so
auth sufficient pam_fprintd.so
auth sufficient pam_unix.so nullok try_first_pass
auth requisite pam_succeed_if.so uid >= 1000 quiet_success
auth sufficient pam_winbind.so use_first_pass
auth required pam_deny.so

account required pam_unix.so broken_shadow
account sufficient pam_localuser.so
account sufficient pam_succeed_if.so uid < 1000 quiet
account [default=bad success=ok user_unknown=ignore] pam_winbind.so
account required pam_permit.so

password requisite pam_pwquality.so try_first_pass local_users_only retry=3 authtok_type=
password sufficient pam_unix.so sha512 shadow nullok try_first_pass use_authtok
password sufficient pam_winbind.so use_authtok
password required pam_deny.so

session optional pam_keyinit.so revoke
session required pam_limits.so
-session optional pam_systemd.so
session optional pam_mkhomedir.so umask=0077
session [success=1 default=ignore] pam_succeed_if.so service in crond quiet use_uid
session required pam_unix.so
session optional pam_mount.so
session optional pam_winbind.so

/etc/security/pam_mount.conf.xml

<?xml version="1.0" encoding="utf-8" ?>
<!DOCTYPE pam_mount SYSTEM "pam_mount.conf.xml.dtd">
<!--
See pam_mount.conf(5) for a description.
-->
<pam_mount>
<!-- debug should come before everything else,
since this file is still processed in a single pass
from top-to-bottom -->
<debug enable="0" />
<!-- Volume definitions -->
<volume fstype="cifs" server="10.2.13.1" path="Documents" mountpoint="~/Documents" />
<!-- pam_mount parameters: General tunables -->
<!--
<luserconf name=".pam_mount.conf.xml" />
-->
<!-- Note that commenting out mntoptions will give you the defaults.
You will need to explicitly initialize it with the empty string
to reset the defaults to nothing. -->
<mntoptions allow="nosuid,nodev,loop,encryption,fsck,nonempty,allow_r oot,allow_other" />
<!--
<mntoptions deny="suid,dev" />
<mntoptions allow="*" />
<mntoptions deny="*" />
-->
<mntoptions require="nosuid,nodev" />
<logout wait="0" hup="0" term="0" kill="0" />
<!-- pam_mount parameters: Volume-related -->
<mkmountpoint enable="1" remove="true" />
</pam_mount>

impuls
27th August 2015, 12:58 PM
Thank you all for your help!
The problem is solved.
In the Ferora 22 it is necessary to make a record about pam_mount not /etc/pam.d/system-auth-ac,
but in /etc/pam.d/password-auth-ac


auth required pam_mount.so
auth required pam_env.so
...
session optional pam_winbind.so
session optional pam_mount.so

Share folder mounted!
:dance: