PDA

View Full Version : [SOLVED] [HELP] Mirror not working



dariodc
14th August 2015, 05:41 PM
Hi all, this is my first thread. Not sure if this is the right place to make my question so if I'm in the wrong place please let me know.
Here's my problem. I've tried to download Fedora 22 via direct download, but the mirror fedora.c3sl.ufpr.br is not working properly and the download fails. I've downloaded by torrent client and installed, but when I try to use the dnf upgrade command I have no response. Got the same issue while trying to install any program with the command line. I've noticed Fedora redirects me to the closest country mirror to download, but that mirror is not working properly and I don't know if there's a possibility to change it.
I know you can edit the sources.list in Debian, but is any way to do that in Fedora??

PS: My apologies for my english and thank you in advance

antikythera
14th August 2015, 06:14 PM
I think you can disable fastestmirror in dnf configuration. there's more information about it here

http://dnf.readthedocs.org/en/latest/conf_ref.html

dariodc
14th August 2015, 09:05 PM
Hi arehtykitna, first at all thank you for your reply. Followed your instructions but it seems I've make things wrong because the problem persist. Forgot to tell that I've installed Fedora 22 on virtual machine, so tried by dumping the iso to an USB stick and running live session, it worked without any issue.
I assume there's a bug related to virtual machines and looks like there isn't any problem with the mirror I've listed before. Any idea about it?? just want to check before mark my problem as solved.
Btw... I'm running virtualbox form Debian repository, not the version downloaded from Oracle

antikythera
15th August 2015, 08:19 AM
Ah, that explains it. The Live ISO contains an older version of DNF that had a few issues communicating with some servers, especially in VM. I experienced the same with UK Mirrors.

Try again with one of these live-respins. They are from a trustworthy source:

http://alt.fedoraproject.org/pub/alt/live-respins/

dariodc
16th August 2015, 06:40 PM
You were right, it's working now so I can wait until F23 is released