PDA

View Full Version : [SOLVED] trying to upgrade from ferdora 21 to 22



ryzee
30th July 2015, 10:54 AM
at the tail end of downloading files for the upgrade I get this message:

NOTE: Some repos could not be contacted: fedy
If you start the upgrade now, packages from these repos will not be installed.

WARNING: problems were encountered during transaction test:
broken dependencies
firewalld-config-workstation-0.3.14.2-2.fc21.noarch requires firewalld-0.3.14.2-2.fc21.noarch
perl-HTTP-Message-6.10-1.fc21.noarch requires perl-4:5.18.4-308.fc21.x86_64
These packages may have problems after the upgrade.


Not sure about being unable to contact fedy, is it all ozonos now? not sure if these messages
are critical or not.

should I just proceed with the upgrade?

DBelton
31st July 2015, 06:38 PM
As for the firewalld issue, I ran into that very same thing when upgrading all of my machines.

What I did was to remove firewalld, then it got re-installed when the upgrade ran.

alextml
1st August 2015, 02:05 AM
Hi,

Have you manage to install it, I am getting the same error messages?

ryzee
2nd August 2015, 01:32 PM
I did successfully upgrade but it did hang at the end and I had to force the reboot
that it claimed it was ready to do "reached target reboot" - there was no disk activity
so I just used a paper clip to force the reboot on the hanging machine. If you let the upgrade
graphic display go (just a blinking fedora logo and a status bar)
without hitting 'esc' it will just stay at fully done for far too long.
hit 'esc' and you will see what has been going on in the background. If you see the "reached
target reboot" message and it hangs, just forcibly reboot and you should be alright, at least
I was, but I wouldn't swear by it. I am convinced that the fedy repo is gone and/or merged with ozonos
but there is no talk of it in the fedora forums.......not sure why but the silence seems to
be growing. Anyway, the main point is that I was able to upgrade despite the message.

---------- Post added at 06:32 AM ---------- Previous post was at 06:30 AM ----------

also the firewall and perl messages amounted to nothing for me - hope it helps