PDA

View Full Version : PyCharm from Fedy Not opening



evilmage93
25th July 2015, 07:31 AM
I am trying to install and use PyCharm on Fedora 22. I tried the following:--

1. First, I installed Fedy and from there I installed Pycharm Professional. But when I tried to open it, it doesn't. The cursor changes to show it is processing something and I can see pycharm written on the top application bar, then after sometime everything returns to normal.

2. Then I tried to download pycharm.tar.gz from the offficial site, extract it and run the pycharm.sh
It results in the following message:-
[moma@localhost bin]$ ./pycharm.sh
OpenJDK 64-Bit Server VM warning: ignoring option MaxPermSize=350m; support was removed in 8.0

Startup Error: Application cannot start in headless mode

Somewhere I read I need to install Java JDK, which I did using Fedy but still neither of the above two methods are working.
ANy Ideas??

Thank You.

marko
25th July 2015, 06:30 PM
I have Pycharm community edition 4.5.3 (141-1899) running on my Fedora 22 laptop. Currently I'm using OpenJDK 1.8.0.51 but just before it was on Oracle 1.8.0.45. All of those worked, I've gone to Openjdk because it's much easier to update (via dnf instead of untarring a file). My launcher for Pycharm in KDE just runs "pycharm.sh" with no special flags

Currently there are few major differences between OpenJDK and Oracle JDK:

http://javapapers.com/java/oracle-jdk-vs-openjdk-and-java-jdk-development-process/

OpenJDK is the reference, then Oracle takes that and puts in some additional features like Mission Control/Flight recorder. I've not seen any reason you'd need to run Pycharm on Oracle jdk

pnelsonsr
25th July 2015, 07:54 PM
You don't have to use the Oracle tar file, they have an rpm that works fine. You will have to download it as I don't think there is a repo for it. Its here (http://www.oracle.com/technetwork/java/javase/downloads/index.html) then click JDK and select 32 or 64 rpm. Once downloaded the process is pretty simple.

dnf install jdk-8u51-linux-x64.rpm #look for in in /usr/java
java -version # to see if its the default and if not
alternatives --config java # set it to the oracle version
# probably want to do the same thing for javac
alternatives --config javac #set it to the oracle version
I have not used OpenJDK in a while because it seemed every other update caused problems with PyCharm or Atlassian or Android-Studio.

marko
25th July 2015, 07:57 PM
You don't have to use the Oracle tar file, they have an rpm that works fine. You will have to download it as I don't think there is a repo for itYes, I know. But just updating the openjdk with dnf directly via the Fedora repos is faster and easier than going to Oracle's JDK webpage, clicking the "Yes I agree" button to the license and then downloading the rpm and then using dnf to install it!
The reports of OpenJDK being slower or quirky compared to Oracle JDK seem like rumors to me. Or it was something going on long ago but now
that OpenJDK is the reference source that Oracle uses anyway to make their version it was something that's gone away.

pnelsonsr
25th July 2015, 08:12 PM
It wasn't rumors that made me go to Oracle. But as I have not been on openjdk in awhile and you have, I'll believe you that things have gotten better. I wish the oracle jdk was in the Fedora Repo or that they had a repo. But they don't update the rpms that often, so I just deal with the few steps once every few months (have a little script to do itl).

Based on your opinion, I may try openjdk again. I do have openjdk-headless installed, so it would be easy to try.

I do have PyCharm 4.5.3 working fine on F22 and have had it working on F19, F20, and F21.

marko
25th July 2015, 08:26 PM
The URL I posted in comment 2 covers the topic pretty well on the differences between them, and it's pretty recent (Dec 2014)