PDA

View Full Version : WOL doesn't work



locodog
24th July 2015, 12:10 PM
I know this topic was raised here many times, but I haven't been able to find solution.
I have ASRock mobo and Atheros AR8152 integrated NIC.

ethtools enp1s0 gives following output
Supports Wake-on: pg
Wake-on: d

I tried "ethtools -s enp1s0 wol g" and it does change to "Wake-on: g", but I'm unable to wake pc over lan. Also after normal booting it reverses itself to "wake-on: d".

Adding
ETHTOOL_OPTS="wol g" to /etc/sysconfig/network-scripts/ifcfg-enp1s0 doesn't help either.

I noticed that when PC is shut down, my NIC led doesn't blink. This also may be relevant, output of "lspci -tv | grep lc"
+-1c.0-[02]--
+-1c.1-[01]----00.0 Qualcomm Atheros AR8152 v2.0 Fast Ethernet


And also content of /proc/acpi/wakeup:

Device S-state Status Sysfs node
P0P2 S4 *disabled pci:0000:00:01.0
P0P3 S4 *disabled
P0P1 S4 *disabled pci:0000:00:1e.0
PS2K S4 *disabled
PS2M S4 *disabled
UAR1 S4 *disabled pnp:00:06
USB0 S4 *enabled pci:0000:00:1d.0
USB1 S4 *enabled pci:0000:00:1d.1
USB2 S4 *enabled pci:0000:00:1d.2
USB3 S4 *enabled pci:0000:00:1d.3
EUSB S4 *enabled pci:0000:00:1d.7
MC97 S4 *disabled
P0P4 S4 *disabled pci:0000:00:1c.0
P0P5 S4 *disabled pci:0000:00:1c.1 <- I believe this should be enabled, but I'm unsure how to do it
P0P6 S4 *disabled
P0P7 S4 *disabled
P0P8 S4 *disabled
P0P9 S4 *disabled
SLPB S4 *disabled

Dutchy
24th July 2015, 12:46 PM
Before driving yourself nuts, first disable all power save features in your pc's firmware (except cpu frequency scaling).

upnort
24th July 2015, 02:13 PM
Ensure WOL is enabled in the BIOS.


I noticed that when PC is shut down, my NIC led doesn't blink.
Check that standby power is available to the motherboard. Most modern motherboards have an LED that indicates standby power is available.

A quirk I have noticed for years is when the NIC is not connected to a live connection when powered down then WOL fails. For example, when the router is powered down first and then the computer is powered down, this leaves the NIC with an open circuit, so to speak. For some reason the Linux kernel gurus decided that with no live network connection the NIC should be disabled on shutdown.

locodog
24th July 2015, 09:28 PM
Before driving yourself nuts, first disable all power save features in your pc's firmware (except cpu frequency scaling).

Only power saving feature I could find is "Dynamic energy saver" and it is set to disabled. Anything else I should look for?

---------- Post added at 10:28 PM ---------- Previous post was at 10:27 PM ----------


Ensure WOL is enabled in the BIOS.


Check that standby power is available to the motherboard. Most modern motherboards have an LED that indicates standby power is available.

A quirk I have noticed for years is when the NIC is not connected to a live connection when powered down then WOL fails. For example, when the router is powered down first and then the computer is powered down, this leaves the NIC with an open circuit, so to speak. For some reason the Linux kernel gurus decided that with no live network connection the NIC should be disabled on shutdown.

My router is always on. Only PC powers down.

Dutchy
25th July 2015, 10:30 AM
Have you looked at this (http://www.asrock.com/support/faq.asp?k=wake+on+lan)?

Peter H.S.
25th July 2015, 01:40 PM
Looking at the ASRock MB's documentation would be a good start, since there are some potential pitfalls like legacy "Energy Star" compliance APM settings hindering the use of WoL. I don't think modern APM is a problem anymore for WoL.

Usually you will need to enter the Bios/UEFI setup and turn on "PCI Devices Power On" or similar. Sometimes it is split between "Power on PCI" and PCIe devices.

Looking at your lspci output, this is ought make WoL work on your MB.

I assume this is an on board NIC you are talking about, since some PCI attached NIC's need a special WoL cable to work.

WoL is a rarely used and tested function on many MB's though, so things don't always work as they should. I have read about people needing to reset their Bios by either reflashing, removing the battery etc., before the WoL function would work across reboots.

locodog
25th July 2015, 05:12 PM
Have you looked at this (http://www.asrock.com/support/faq.asp?k=wake+on+lan)?

Thanks for suggestion, but that was first thing I did. On my previous PC enabling Wake On Lan in BIOS was enough (it was Gigabyte mobo), but on ASRock, for some reason it doesn't work.